summaryrefslogtreecommitdiffstats
path: root/dbaccess/Library_dbahsql.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /dbaccess/Library_dbahsql.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dbaccess/Library_dbahsql.mk')
-rw-r--r--dbaccess/Library_dbahsql.mk51
1 files changed, 51 insertions, 0 deletions
diff --git a/dbaccess/Library_dbahsql.mk b/dbaccess/Library_dbahsql.mk
new file mode 100644
index 0000000000..7929e9bd6a
--- /dev/null
+++ b/dbaccess/Library_dbahsql.mk
@@ -0,0 +1,51 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,dbahsql))
+
+$(eval $(call gb_Library_set_include,dbahsql,\
+ $$(INCLUDE) \
+ -I$(WORKDIR)/YaccTarget/connectivity/source/parse \
+))
+
+$(eval $(call gb_Library_use_externals,dbahsql,\
+ boost_headers \
+ boost_date_time \
+))
+
+$(eval $(call gb_Library_set_precompiled_header,dbahsql,dbaccess/inc/pch/precompiled_dbahsql))
+
+$(eval $(call gb_Library_use_sdk_api,dbahsql))
+
+$(eval $(call gb_Library_use_libraries,dbahsql,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ salhelper \
+ dbtools \
+ ucbhelper \
+ utl \
+ tl \
+))
+
+$(eval $(call gb_Library_add_exception_objects,dbahsql,\
+ dbaccess/source/filter/hsqldb/hsqlimport \
+ dbaccess/source/filter/hsqldb/parseschema \
+ dbaccess/source/filter/hsqldb/alterparser \
+ dbaccess/source/filter/hsqldb/createparser \
+ dbaccess/source/filter/hsqldb/columndef \
+ dbaccess/source/filter/hsqldb/fbalterparser \
+ dbaccess/source/filter/hsqldb/fbcreateparser \
+ dbaccess/source/filter/hsqldb/rowinputbinary \
+ dbaccess/source/filter/hsqldb/hsqlbinarynode \
+ dbaccess/source/filter/hsqldb/utils \
+))
+
+# vim: set noet sw=4 ts=4: