summaryrefslogtreecommitdiffstats
path: root/docmodel/Library_docmodel.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /docmodel/Library_docmodel.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'docmodel/Library_docmodel.mk')
-rw-r--r--docmodel/Library_docmodel.mk48
1 files changed, 48 insertions, 0 deletions
diff --git a/docmodel/Library_docmodel.mk b/docmodel/Library_docmodel.mk
new file mode 100644
index 0000000000..d5f4531602
--- /dev/null
+++ b/docmodel/Library_docmodel.mk
@@ -0,0 +1,48 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t; fill-column: 100 -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,docmodel))
+
+$(eval $(call gb_Library_add_exception_objects,docmodel,\
+ docmodel/source/uno/UnoComplexColor \
+ docmodel/source/uno/UnoGradientTools \
+ docmodel/source/uno/UnoTheme \
+ docmodel/source/theme/ColorSet \
+ docmodel/source/theme/Theme \
+ docmodel/source/color/ComplexColorJSON \
+))
+
+$(eval $(call gb_Library_set_include,docmodel,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/docmodel/inc \
+))
+
+$(eval $(call gb_Library_use_externals,docmodel,\
+ libxml2 \
+ boost_headers \
+))
+
+$(eval $(call gb_Library_add_defs,docmodel,\
+ -DDOCMODEL_DLLIMPLEMENTATION \
+))
+
+$(eval $(call gb_Library_set_precompiled_header,docmodel,docmodel/inc/pch/precompiled_docmodel))
+
+$(eval $(call gb_Library_use_sdk_api,docmodel))
+
+$(eval $(call gb_Library_use_libraries,docmodel,\
+ basegfx \
+ comphelper \
+ cppuhelper \
+ cppu \
+ sal \
+ tl \
+))
+
+# vim: set noet sw=4 ts=4: