summaryrefslogtreecommitdiffstats
path: root/embedserv/Library_inprocserv.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /embedserv/Library_inprocserv.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'embedserv/Library_inprocserv.mk')
-rw-r--r--embedserv/Library_inprocserv.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/embedserv/Library_inprocserv.mk b/embedserv/Library_inprocserv.mk
new file mode 100644
index 0000000000..ee9c25497d
--- /dev/null
+++ b/embedserv/Library_inprocserv.mk
@@ -0,0 +1,36 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,inprocserv))
+
+$(eval $(call gb_Library_set_include,inprocserv,\
+ -I$(SRCDIR)/embedserv/source/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_use_system_win32_libs,inprocserv,\
+ gdi32 \
+ ole32 \
+ uuid \
+))
+
+ifeq ($(COM),MSC)
+$(eval $(call gb_Library_add_ldflags,inprocserv,\
+ /DEF:$(SRCDIR)/embedserv/source/inprocserv/inprocserv.def \
+))
+endif
+
+$(eval $(call gb_Library_add_exception_objects,inprocserv,\
+ embedserv/source/inprocserv/advisesink \
+ embedserv/source/inprocserv/dllentry \
+ embedserv/source/inprocserv/inprocembobj \
+))
+
+# vim: set noet sw=4 ts=4: