summaryrefslogtreecommitdiffstats
path: root/extensions/CppunitTest_extensions_test_update.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /extensions/CppunitTest_extensions_test_update.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extensions/CppunitTest_extensions_test_update.mk')
-rw-r--r--extensions/CppunitTest_extensions_test_update.mk66
1 files changed, 66 insertions, 0 deletions
diff --git a/extensions/CppunitTest_extensions_test_update.mk b/extensions/CppunitTest_extensions_test_update.mk
new file mode 100644
index 0000000000..da6b83a311
--- /dev/null
+++ b/extensions/CppunitTest_extensions_test_update.mk
@@ -0,0 +1,66 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,extensions_test_update))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,extensions_test_update, \
+ extensions/qa/update/test_update \
+))
+
+$(eval $(call gb_CppunitTest_use_external,extensions_test_update,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_libraries,extensions_test_update, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ salhelper \
+ test \
+ utl \
+ unotest \
+ vcl \
+))
+
+$(eval $(call gb_CppunitTest_use_library_objects,extensions_test_update, \
+ updchk \
+))
+
+ifeq ($(OS),WNT)
+$(eval $(call gb_CppunitTest_use_system_win32_libs,extensions_test_update,\
+ shell32 \
+ ole32 \
+ wininet \
+))
+endif
+
+$(eval $(call gb_CppunitTest_use_external,extensions_test_update,curl))
+
+$(eval $(call gb_CppunitTest_set_include,extensions_test_update,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/extensions/inc \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,extensions_test_update))
+
+$(eval $(call gb_CppunitTest_use_ure,extensions_test_update))
+$(eval $(call gb_CppunitTest_use_vcl,extensions_test_update))
+
+$(eval $(call gb_CppunitTest_use_components,extensions_test_update,\
+ configmgr/source/configmgr \
+ extensions/source/update/feed/updatefeed \
+ ucb/source/core/ucb1 \
+ ucb/source/ucp/file/ucpfile1 \
+ unoxml/source/service/unoxml \
+))
+
+$(eval $(call gb_CppunitTest_use_configuration,extensions_test_update))
+
+# vim:set shiftwidth=4 softtabstop=4 noexpandtab: