summaryrefslogtreecommitdiffstats
path: root/extensions/Library_bib.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /extensions/Library_bib.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extensions/Library_bib.mk')
-rw-r--r--extensions/Library_bib.mk58
1 files changed, 58 insertions, 0 deletions
diff --git a/extensions/Library_bib.mk b/extensions/Library_bib.mk
new file mode 100644
index 0000000000..147b8034f3
--- /dev/null
+++ b/extensions/Library_bib.mk
@@ -0,0 +1,58 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#
+
+$(eval $(call gb_Library_Library,bib))
+
+$(eval $(call gb_Library_set_componentfile,bib,extensions/source/bibliography/bib,services))
+
+$(eval $(call gb_Library_set_include,bib,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/extensions/inc \
+))
+
+$(eval $(call gb_Library_use_external,bib,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,bib))
+
+$(eval $(call gb_Library_add_exception_objects,bib,\
+ extensions/source/bibliography/bibbeam \
+ extensions/source/bibliography/bibconfig \
+ extensions/source/bibliography/bibcont \
+ extensions/source/bibliography/bibload \
+ extensions/source/bibliography/bibmod \
+ extensions/source/bibliography/bibview \
+ extensions/source/bibliography/datman \
+ extensions/source/bibliography/formcontrolcontainer \
+ extensions/source/bibliography/framectr \
+ extensions/source/bibliography/general \
+ extensions/source/bibliography/loadlisteneradapter \
+ extensions/source/bibliography/toolbar \
+))
+
+$(eval $(call gb_Library_use_libraries,bib,\
+ dbtools \
+ sfx \
+ sot \
+ svt \
+ svl \
+ tk \
+ vcl \
+ utl \
+ tl \
+ comphelper \
+ cppuhelper \
+ cppu \
+ sal \
+ salhelper \
+ i18nlangtag \
+))
+
+# vim:set noet sw=4 ts=4: