summaryrefslogtreecommitdiffstats
path: root/extensions/Library_updchk.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /extensions/Library_updchk.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extensions/Library_updchk.mk')
-rw-r--r--extensions/Library_updchk.mk61
1 files changed, 61 insertions, 0 deletions
diff --git a/extensions/Library_updchk.mk b/extensions/Library_updchk.mk
new file mode 100644
index 0000000000..85c0293231
--- /dev/null
+++ b/extensions/Library_updchk.mk
@@ -0,0 +1,61 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,updchk))
+
+$(eval $(call gb_Library_set_componentfile,updchk,extensions/source/update/check/updchk.uno,services))
+
+$(eval $(call gb_Library_set_include,updchk,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/extensions/inc \
+))
+
+$(eval $(call gb_Library_use_sdk_api,updchk))
+
+$(eval $(call gb_Library_use_custom_headers,updchk,\
+ officecfg/registry \
+))
+
+$(eval $(call gb_Library_use_libraries,updchk,\
+ comphelper \
+ cppuhelper \
+ cppu \
+ sal \
+ salhelper \
+ utl \
+ vcl \
+))
+
+ifeq ($(OS),WNT)
+$(eval $(call gb_Library_use_system_win32_libs,updchk,\
+ ole32 \
+ shell32 \
+ wininet \
+))
+
+$(eval $(call gb_Library_add_exception_objects,updchk,\
+ extensions/source/update/check/onlinecheck \
+))
+endif # OS WNT
+
+$(eval $(call gb_Library_use_externals,updchk,\
+ boost_headers \
+ curl \
+))
+
+$(eval $(call gb_Library_add_exception_objects,updchk,\
+ extensions/source/update/check/download \
+ extensions/source/update/check/updatecheck \
+ extensions/source/update/check/updatecheckconfig \
+ extensions/source/update/check/updatecheckjob \
+ extensions/source/update/check/updatehdl \
+ extensions/source/update/check/updateprotocol \
+))
+
+# vim:set noet sw=4 ts=4: