summaryrefslogtreecommitdiffstats
path: root/external/IAccessible2
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /external/IAccessible2
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'external/IAccessible2')
-rw-r--r--external/IAccessible2/ExternalProject_IAccessible2.mk26
-rw-r--r--external/IAccessible2/Module_IAccessible2.mk17
-rw-r--r--external/IAccessible2/README5
-rw-r--r--external/IAccessible2/UnpackedTarball_IAccessible2.mk14
4 files changed, 62 insertions, 0 deletions
diff --git a/external/IAccessible2/ExternalProject_IAccessible2.mk b/external/IAccessible2/ExternalProject_IAccessible2.mk
new file mode 100644
index 0000000000..0ef6c8fc60
--- /dev/null
+++ b/external/IAccessible2/ExternalProject_IAccessible2.mk
@@ -0,0 +1,26 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_ExternalProject_ExternalProject,IAccessible2))
+
+$(eval $(call gb_ExternalProject_register_targets,IAccessible2,\
+ build \
+))
+
+# run IAccessible2's 'concatidl.sh' script that creates the merged .idl file,
+# 'ia2_api_all.idl'
+$(call gb_ExternalProject_get_state_target,IAccessible2,build) :
+ $(call gb_Trace_StartRange,IAccessible2,EXTERNAL)
+ $(call gb_ExternalProject_run,build,\
+ cd $(call gb_UnpackedTarball_get_dir,IAccessible2)\
+ && ./concatidl.sh\
+ )
+ $(call gb_Trace_EndRange,IAccessible2,EXTERNAL)
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/IAccessible2/Module_IAccessible2.mk b/external/IAccessible2/Module_IAccessible2.mk
new file mode 100644
index 0000000000..a1013ec835
--- /dev/null
+++ b/external/IAccessible2/Module_IAccessible2.mk
@@ -0,0 +1,17 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t; fill-column: 100 -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,IAccessible2))
+
+$(eval $(call gb_Module_add_targets,IAccessible2,\
+ UnpackedTarball_IAccessible2 \
+ ExternalProject_IAccessible2 \
+))
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/IAccessible2/README b/external/IAccessible2/README
new file mode 100644
index 0000000000..511880d77d
--- /dev/null
+++ b/external/IAccessible2/README
@@ -0,0 +1,5 @@
+IAccessible2 is an accessibility API which complements Microsoft's earlier work on MSAA.
+
+It is used for LibreOffice's Windows accessibility bridge in the winaccessibility module.
+
+IAccessible2 is available from [ https://github.com/LinuxA11y/IAccessible2/ ].
diff --git a/external/IAccessible2/UnpackedTarball_IAccessible2.mk b/external/IAccessible2/UnpackedTarball_IAccessible2.mk
new file mode 100644
index 0000000000..b24988aece
--- /dev/null
+++ b/external/IAccessible2/UnpackedTarball_IAccessible2.mk
@@ -0,0 +1,14 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t; fill-column: 100 -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_UnpackedTarball_UnpackedTarball,IAccessible2))
+
+$(eval $(call gb_UnpackedTarball_set_tarball,IAccessible2,$(IACCESSIBLE2_TARBALL)))
+
+# vim: set noet sw=4 ts=4: