summaryrefslogtreecommitdiffstats
path: root/jvmfwk/Module_jvmfwk.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /jvmfwk/Module_jvmfwk.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'jvmfwk/Module_jvmfwk.mk')
-rw-r--r--jvmfwk/Module_jvmfwk.mk37
1 files changed, 37 insertions, 0 deletions
diff --git a/jvmfwk/Module_jvmfwk.mk b/jvmfwk/Module_jvmfwk.mk
new file mode 100644
index 0000000000..802daed570
--- /dev/null
+++ b/jvmfwk/Module_jvmfwk.mk
@@ -0,0 +1,37 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,jvmfwk))
+
+ifeq ($(ENABLE_JAVA),TRUE)
+
+$(eval $(call gb_Module_add_targets,jvmfwk,\
+ CustomTarget_jreproperties \
+ CustomTarget_jvmfwk_jvmfwk3_ini \
+ Library_jvmfwk \
+ Package_jreproperties \
+ Package_jvmfwk_jvmfwk3_ini \
+ Package_rcfiles \
+))
+
+ifneq (,$(filter-out MACOSX WNT,$(OS)))
+ifneq (,$(filter DESKTOP,$(BUILD_TYPE)))
+$(eval $(call gb_Module_add_targets,jvmfwk,\
+ Executable_javaldx \
+))
+endif
+endif
+
+$(eval $(call gb_Module_add_check_targets,jvmfwk, \
+ CppunitTest_jvmfwk_sunversion \
+))
+
+endif
+
+# vim:set noet sw=4 ts=4: