summaryrefslogtreecommitdiffstats
path: root/linguistic/Module_linguistic.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /linguistic/Module_linguistic.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--linguistic/Module_linguistic.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/linguistic/Module_linguistic.mk b/linguistic/Module_linguistic.mk
new file mode 100644
index 0000000000..b5366b97e6
--- /dev/null
+++ b/linguistic/Module_linguistic.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,linguistic))
+
+$(eval $(call gb_Module_add_targets,linguistic,\
+ Library_lng \
+))
+
+#$(eval $(call gb_Module_add_check_targets,linguistic,\
+#))
+
+ifeq ($(OS),LINUX)
+$(eval $(call gb_Module_add_subsequentcheck_targets,linguistic,\
+ JunitTest_linguistic_unoapi \
+ CppunitTest_linguistic_restprotocol \
+))
+else
+$(eval $(call gb_Module_add_subsequentcheck_targets,linguistic,\
+ JunitTest_linguistic_unoapi \
+))
+endif
+
+# was disabled in old build system
+# JunitTest_linguistic_complex \
+
+# vim: set noet sw=4 ts=4: