summaryrefslogtreecommitdiffstats
path: root/odk/CustomTarget_classes.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /odk/CustomTarget_classes.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'odk/CustomTarget_classes.mk')
-rw-r--r--odk/CustomTarget_classes.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/odk/CustomTarget_classes.mk b/odk/CustomTarget_classes.mk
new file mode 100644
index 0000000000..68666b4cd6
--- /dev/null
+++ b/odk/CustomTarget_classes.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,odk/classes))
+
+$(eval $(call gb_CustomTarget_register_targets,odk/classes,\
+ java.done \
+))
+
+$(eval $(call gb_JavaClassSet_JavaClassSet,loader))
+
+$(eval $(call gb_JavaClassSet_add_sourcefiles,loader,\
+ odk/source/com/sun/star/lib/loader/Loader \
+ odk/source/com/sun/star/lib/loader/InstallationFinder \
+ odk/source/com/sun/star/lib/loader/WinRegKey \
+ odk/source/com/sun/star/lib/loader/WinRegKeyException \
+))
+
+$(call gb_CustomTarget_get_workdir,odk/classes)/java.done: $(call gb_JavaClassSet_get_target,loader)
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),build,CPY,1)
+ cp -a $(call gb_JavaClassSet_get_classdir,loader)/com $(dir $@) && \
+ touch $@
+
+# vim: set noet sw=4 ts=4: