summaryrefslogtreecommitdiffstats
path: root/odk/Package_share_readme.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /odk/Package_share_readme.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'odk/Package_share_readme.mk')
-rw-r--r--odk/Package_share_readme.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/odk/Package_share_readme.mk b/odk/Package_share_readme.mk
new file mode 100644
index 0000000000..bb97b83964
--- /dev/null
+++ b/odk/Package_share_readme.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+readlicense_oo_DIR := $(call gb_CustomTarget_get_workdir,readlicense_oo/license)
+$(eval $(call gb_Package_Package,odk_share_readme,$(readlicense_oo_DIR)))
+
+$(eval $(call gb_Package_set_outdir,odk_share_readme,$(INSTDIR)))
+
+$(eval $(call gb_Package_add_files,odk_share_readme,$(SDKDIRNAME)/share/readme,\
+ LICENSE.html \
+))
+
+# for WNT see Package_share_readme_generated.mk
+ifneq ($(OS),WNT)
+$(eval $(call gb_Package_add_file,odk_share_readme,$(SDKDIRNAME)/share/readme/LICENSE,LICENSE))
+endif
+
+# vim: set noet sw=4 ts=4: