summaryrefslogtreecommitdiffstats
path: root/ridljar/Module_ridljar.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /ridljar/Module_ridljar.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--ridljar/Module_ridljar.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/ridljar/Module_ridljar.mk b/ridljar/Module_ridljar.mk
new file mode 100644
index 0000000000..3d286c5461
--- /dev/null
+++ b/ridljar/Module_ridljar.mk
@@ -0,0 +1,36 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,ridljar))
+
+ifneq ($(ENABLE_JAVA),)
+
+$(eval $(call gb_Module_add_targets,ridljar,\
+ CustomTarget_javamaker \
+ Jar_libreoffice \
+ Jar_ridl \
+ Jar_unoloader \
+))
+
+$(eval $(call gb_Module_add_check_targets,ridljar,\
+ CustomTarget_test_urp \
+ InternalUnoApi_test_urp \
+ JunitTest_bridgefactory \
+ JunitTest_connections \
+ JunitTest_java \
+ JunitTest_java_remote \
+ JunitTest_remote \
+ JunitTest_typedesc \
+ JunitTest_uno \
+ JunitTest_urp \
+ JunitTest_util \
+))
+endif
+
+# vim:set noet sw=4 ts=4: