summaryrefslogtreecommitdiffstats
path: root/sal/Module_sal.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /sal/Module_sal.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sal/Module_sal.mk')
-rw-r--r--sal/Module_sal.mk42
1 files changed, 42 insertions, 0 deletions
diff --git a/sal/Module_sal.mk b/sal/Module_sal.mk
new file mode 100644
index 0000000000..854d46a8e6
--- /dev/null
+++ b/sal/Module_sal.mk
@@ -0,0 +1,42 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,sal))
+
+$(eval $(call gb_Module_add_targets,sal,\
+ $(if $(CROSS_COMPILING),,$(if $(filter TRUE,$(DISABLE_DYNLOADING)),,Executable_cppunittester)) \
+ $(if $(filter $(OS),ANDROID EMSCRIPTEN), \
+ Library_lo-bootstrap) \
+ Library_sal \
+ $(call gb_CondLibSalTextenc,Library_sal_textenc) \
+))
+
+ifneq (,$(filter DESKTOP,$(BUILD_TYPE)))
+
+ifneq (EMSCRIPTEN,$(OS))
+$(eval $(call gb_Module_add_targets,sal,\
+ Executable_osl_process_child \
+))
+endif
+
+$(eval $(call gb_Module_add_check_targets,sal,\
+ $(if $(filter TRUE,$(DISABLE_DYNLOADING)),,CppunitTest_Module_DLL) \
+ $(if $(filter WNT,$(OS)),CppunitTest_sal_comtools) \
+ $(if $(filter WNT,$(OS)),CppunitTest_sal_retry_if_failed) \
+ CppunitTest_sal_osl_security \
+ CppunitTest_sal_osl \
+ CppunitTest_sal_rtl \
+ CppunitTest_sal_types \
+ $(if $(COM_IS_CLANG),$(if $(COMPILER_EXTERNAL_TOOL)$(COMPILER_PLUGIN_TOOL),, \
+ CompilerTest_sal_rtl_oustring)) \
+))
+
+endif
+
+# vim: set noet sw=4 ts=4: