summaryrefslogtreecommitdiffstats
path: root/shell/Library_kf5be.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /shell/Library_kf5be.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'shell/Library_kf5be.mk')
-rw-r--r--shell/Library_kf5be.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/shell/Library_kf5be.mk b/shell/Library_kf5be.mk
new file mode 100644
index 0000000000..1355d402dc
--- /dev/null
+++ b/shell/Library_kf5be.mk
@@ -0,0 +1,40 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,kf5be1))
+
+$(eval $(call gb_Library_use_sdk_api,kf5be1))
+
+$(eval $(call gb_Library_use_externals,kf5be1,\
+ kf5 \
+))
+
+$(eval $(call gb_Library_use_libraries,kf5be1,\
+ cppu \
+ cppuhelper \
+ sal \
+ vcl \
+))
+
+$(eval $(call gb_Library_set_componentfile,kf5be1,shell/source/backends/kf5be/kf5be1,services))
+
+$(eval $(call gb_Library_add_exception_objects,kf5be1,\
+ shell/source/backends/kf5be/kf5access \
+ shell/source/backends/kf5be/kf5backend \
+))
+
+# Workaround for clang+icecream (clang's -frewrite-includes
+# doesn't handle Qt5's QT_HAS_INCLUDE that Qt5 uses for <chrono>).
+ifeq ($(COM_IS_CLANG),TRUE)
+$(eval $(call gb_Library_add_cxxflags,kf5be1, \
+ -include chrono \
+))
+endif
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: