summaryrefslogtreecommitdiffstats
path: root/shell/StaticLibrary_xmlparser.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /shell/StaticLibrary_xmlparser.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'shell/StaticLibrary_xmlparser.mk')
-rw-r--r--shell/StaticLibrary_xmlparser.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/shell/StaticLibrary_xmlparser.mk b/shell/StaticLibrary_xmlparser.mk
new file mode 100644
index 0000000000..ee49f076fe
--- /dev/null
+++ b/shell/StaticLibrary_xmlparser.mk
@@ -0,0 +1,25 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_StaticLibrary_StaticLibrary,shell_xmlparser))
+
+$(eval $(call gb_StaticLibrary_set_include,shell_xmlparser,\
+ -I$(SRCDIR)/shell/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_StaticLibrary_use_externals,shell_xmlparser,\
+ expat \
+))
+
+$(eval $(call gb_StaticLibrary_add_exception_objects,shell_xmlparser,\
+ shell/source/all/xml_parser \
+))
+
+# vim: set shiftwidth=4 tabstop=4 noexpandtab: