summaryrefslogtreecommitdiffstats
path: root/smoketest/Library_smoketest.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /smoketest/Library_smoketest.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'smoketest/Library_smoketest.mk')
-rw-r--r--smoketest/Library_smoketest.mk37
1 files changed, 37 insertions, 0 deletions
diff --git a/smoketest/Library_smoketest.mk b/smoketest/Library_smoketest.mk
new file mode 100644
index 0000000000..b7751491a4
--- /dev/null
+++ b/smoketest/Library_smoketest.mk
@@ -0,0 +1,37 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+# this is a Library that contains a unit test, so it can be packaged
+$(eval $(call gb_Library_Library,smoketest))
+
+# necessary because this is no CppUnitTest but a Library
+$(eval $(call gb_Library_add_defs,smoketest,\
+ -DCPPUNIT_PLUGIN_EXPORT='extern "C" SAL_DLLPUBLIC_EXPORT' \
+))
+
+$(eval $(call gb_Library_use_sdk_api,smoketest))
+
+$(eval $(call gb_Library_use_libraries,smoketest,\
+ cppu \
+ cppuhelper \
+ sal \
+ unotest \
+))
+
+$(eval $(call gb_Library_use_externals,smoketest,\
+ boost_headers \
+ cppunit \
+))
+
+$(eval $(call gb_Library_add_exception_objects,smoketest,\
+ smoketest/smoketest \
+))
+
+# vim: set noet sw=4 ts=4: