summaryrefslogtreecommitdiffstats
path: root/smoketest/Module_smoketest.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /smoketest/Module_smoketest.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'smoketest/Module_smoketest.mk')
-rw-r--r--smoketest/Module_smoketest.mk47
1 files changed, 47 insertions, 0 deletions
diff --git a/smoketest/Module_smoketest.mk b/smoketest/Module_smoketest.mk
new file mode 100644
index 0000000000..5d66a0daa1
--- /dev/null
+++ b/smoketest/Module_smoketest.mk
@@ -0,0 +1,47 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,smoketest))
+
+ifeq ($(CROSS_COMPILING),)
+
+ifneq (,$(filter DESKTOP,$(BUILD_TYPE)))
+$(eval $(call gb_Module_add_targets,smoketest,\
+ Library_smoketest \
+ Zip_smoketestdoc \
+))
+endif
+
+ifneq ($(ENABLE_JAVA),)
+ifneq ($(filter EXTENSIONS,$(BUILD_TYPE)),)
+$(eval $(call gb_Module_add_targets,smoketest,\
+ Extension_TestExtension \
+ Jar_TestExtension \
+))
+endif
+endif
+
+ifneq (MACOSX/TRUE,$(OS)/$(ENABLE_MACOSX_SANDBOX))
+ifneq ($(filter EXTENSIONS,$(BUILD_TYPE)),)
+$(eval $(call gb_Module_add_subsequentcheck_targets,smoketest,\
+ CppunitTest_smoketest \
+))
+endif
+endif
+
+endif
+
+ifneq ($(ENABLE_JAVA),)
+$(eval $(call gb_Module_add_targets,smoketest,\
+ Jar_smoketest \
+))
+endif
+
+# vim: set noet sw=4 ts=4: