summaryrefslogtreecommitdiffstats
path: root/stoc/Library_javavm.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /stoc/Library_javavm.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'stoc/Library_javavm.mk')
-rw-r--r--stoc/Library_javavm.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/stoc/Library_javavm.mk b/stoc/Library_javavm.mk
new file mode 100644
index 0000000000..adcb49691c
--- /dev/null
+++ b/stoc/Library_javavm.mk
@@ -0,0 +1,40 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,javavm))
+
+$(eval $(call gb_Library_use_external,javavm,boost_headers))
+
+$(eval $(call gb_Library_use_udk_api,javavm))
+
+$(eval $(call gb_Library_use_libraries,javavm,\
+ cppu \
+ cppuhelper \
+ i18nlangtag \
+ jvmaccess \
+ jvmfwk \
+ sal \
+ salhelper \
+))
+
+$(eval $(call gb_Library_set_componentfile,javavm,stoc/source/javavm/javavm,ure/services))
+
+$(eval $(call gb_Library_add_exception_objects,javavm,\
+ stoc/source/javavm/interact \
+ stoc/source/javavm/javavm \
+ stoc/source/javavm/jvmargs \
+))
+
+ifeq ($(OS),MACOSX)
+$(eval $(call gb_Library_use_system_darwin_frameworks,javavm,\
+ CoreFoundation \
+))
+endif
+
+# vim:set noet sw=4 ts=4: