summaryrefslogtreecommitdiffstats
path: root/sw/CppunitTest_sw_apiterminate.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /sw/CppunitTest_sw_apiterminate.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sw/CppunitTest_sw_apiterminate.mk')
-rw-r--r--sw/CppunitTest_sw_apiterminate.mk44
1 files changed, 44 insertions, 0 deletions
diff --git a/sw/CppunitTest_sw_apiterminate.mk b/sw/CppunitTest_sw_apiterminate.mk
new file mode 100644
index 0000000000..c6228cf72d
--- /dev/null
+++ b/sw/CppunitTest_sw_apiterminate.mk
@@ -0,0 +1,44 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t; fill-column: 100 -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,sw_apiterminate))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,sw_apiterminate, \
+ sw/qa/api/terminate \
+))
+
+$(eval $(call gb_CppunitTest_use_api,sw_apiterminate, \
+ offapi \
+ udkapi \
+))
+
+$(eval $(call gb_CppunitTest_use_common_precompiled_header,sw_apiterminate))
+
+$(eval $(call gb_CppunitTest_use_configuration,sw_apiterminate))
+
+$(eval $(call gb_CppunitTest_use_libraries,sw_apiterminate, \
+ comphelper \
+ cppu \
+ sal \
+ subsequenttest \
+ test \
+ unotest \
+))
+
+$(eval $(call gb_CppunitTest_use_rdb,sw_apiterminate,services))
+
+$(eval $(call gb_CppunitTest_use_vcl,sw_apiterminate))
+
+$(eval $(call gb_CppunitTest_use_uiconfigs,sw_apiterminate, \
+ svx \
+))
+
+$(eval $(call gb_CppunitTest_use_ure,sw_apiterminate))
+
+# vim: set noet sw=4 ts=4: