summaryrefslogtreecommitdiffstats
path: root/sw/Library_swqahelper.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /sw/Library_swqahelper.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'sw/Library_swqahelper.mk')
-rw-r--r--sw/Library_swqahelper.mk71
1 files changed, 71 insertions, 0 deletions
diff --git a/sw/Library_swqahelper.mk b/sw/Library_swqahelper.mk
new file mode 100644
index 0000000000..ec379d9796
--- /dev/null
+++ b/sw/Library_swqahelper.mk
@@ -0,0 +1,71 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,swqahelper))
+
+$(eval $(call gb_Library_set_include,swqahelper,\
+ -I$(SRCDIR)/sw/inc \
+ -I$(SRCDIR)/sw/source/core/inc \
+ -I$(SRCDIR)/sw/qa/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_use_custom_headers,swqahelper,\
+ officecfg/registry \
+))
+
+$(eval $(call gb_Library_use_externals,swqahelper, \
+ boost_headers \
+ cppunit \
+ libxml2 \
+))
+
+$(eval $(call gb_Library_use_custom_headers,swqahelper,\
+ officecfg/registry \
+))
+
+$(eval $(call gb_Library_add_defs,swqahelper,\
+ -DSWQAHELPER_DLLIMPLEMENTATION \
+))
+
+$(eval $(call gb_Library_use_api,swqahelper,\
+ udkapi \
+ offapi \
+ oovbaapi \
+))
+
+$(eval $(call gb_Library_use_libraries,swqahelper,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ editeng \
+ for \
+ sal \
+ sw \
+ sfx \
+ sot \
+ subsequenttest \
+ svl \
+ svt \
+ svx \
+ svxcore \
+ test \
+ tl \
+ unotest \
+ utl \
+ ucbhelper \
+ unotest \
+ vcl \
+))
+
+$(eval $(call gb_Library_add_exception_objects,swqahelper,\
+ sw/qa/unit/swmodeltestbase \
+))
+
+# vim: set noet sw=4 ts=4: