summaryrefslogtreecommitdiffstats
path: root/swext/Module_swext.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /swext/Module_swext.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'swext/Module_swext.mk')
-rw-r--r--swext/Module_swext.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/swext/Module_swext.mk b/swext/Module_swext.mk
new file mode 100644
index 0000000000..0a5462c18f
--- /dev/null
+++ b/swext/Module_swext.mk
@@ -0,0 +1,19 @@
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#
+
+$(eval $(call gb_Module_Module,swext))
+
+ifeq ($(ENABLE_MEDIAWIKI),TRUE)
+$(eval $(call gb_Module_add_targets,swext,\
+ Jar_mediawiki \
+ Configuration_mediawiki \
+ Extension_wiki-publisher \
+))
+endif