summaryrefslogtreecommitdiffstats
path: root/test/Library_vclbootstrapprotector.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /test/Library_vclbootstrapprotector.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/Library_vclbootstrapprotector.mk')
-rw-r--r--test/Library_vclbootstrapprotector.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/test/Library_vclbootstrapprotector.mk b/test/Library_vclbootstrapprotector.mk
new file mode 100644
index 0000000000..d01bc66795
--- /dev/null
+++ b/test/Library_vclbootstrapprotector.mk
@@ -0,0 +1,34 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,vclbootstrapprotector))
+
+$(eval $(call gb_Library_add_exception_objects,vclbootstrapprotector, \
+ test/source/vclbootstrapprotector \
+))
+
+$(eval $(call gb_Library_use_externals,vclbootstrapprotector, \
+ boost_headers \
+ cppunit \
+))
+
+$(eval $(call gb_Library_use_libraries,vclbootstrapprotector, \
+ comphelper \
+ cppu \
+ i18nlangtag \
+ sal \
+ test-setupvcl \
+ tl \
+ utl \
+ vcl \
+))
+
+$(eval $(call gb_Library_use_sdk_api,vclbootstrapprotector))
+
+# vim: set noet sw=4 ts=4: