summaryrefslogtreecommitdiffstats
path: root/testtools/Library_cppobj.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /testtools/Library_cppobj.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testtools/Library_cppobj.mk')
-rw-r--r--testtools/Library_cppobj.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/testtools/Library_cppobj.mk b/testtools/Library_cppobj.mk
new file mode 100644
index 0000000000..3019b330da
--- /dev/null
+++ b/testtools/Library_cppobj.mk
@@ -0,0 +1,40 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,testtools_cppobj))
+
+$(eval $(call gb_Library_set_componentfile,testtools_cppobj,testtools/source/bridgetest/cppobj,uno_services))
+
+$(eval $(call gb_Executable_set_include,testtools_cppobj,\
+ -I$(SRCDIR)/testtools/source/bridgetest \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_use_internal_api,testtools_cppobj,\
+ bridgetest \
+))
+
+$(eval $(call gb_Library_use_api,testtools_cppobj,\
+ udkapi \
+))
+
+$(eval $(call gb_Library_use_external,testtools_cppobj,boost_headers))
+
+$(eval $(call gb_Library_use_libraries,testtools_cppobj,\
+ cppu \
+ cppuhelper \
+ sal \
+ testtools_bridgetest-common \
+))
+
+$(eval $(call gb_Library_add_exception_objects,testtools_cppobj,\
+ testtools/source/bridgetest/cppobj \
+))
+
+# vim:set noet sw=4 ts=4: