summaryrefslogtreecommitdiffstats
path: root/unoidl/Module_unoidl.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /unoidl/Module_unoidl.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'unoidl/Module_unoidl.mk')
-rw-r--r--unoidl/Module_unoidl.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/unoidl/Module_unoidl.mk b/unoidl/Module_unoidl.mk
new file mode 100644
index 0000000000..1553371774
--- /dev/null
+++ b/unoidl/Module_unoidl.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,unoidl))
+
+# unoidl-check is needed as a component of the ODK / SDK package and
+# a build-tool. In case of cross-compiling a build-native tool must
+# be provided in addtion to the ODK one (!CROSS_COMPLING phase).
+
+$(eval $(call gb_Module_add_targets,unoidl, \
+ $(if $(filter DESKTOP,$(BUILD_TYPE)), \
+ Executable_unoidl-read) \
+ $(if $(or $(filter ODK,$(BUILD_TYPE)),$(call gb_not,$(CROSS_COMPILING))), \
+ Executable_unoidl-check \
+ Executable_unoidl-write \
+ ) \
+ Library_unoidl \
+))
+
+$(eval $(call gb_Module_add_check_targets,unoidl, \
+ CustomTarget_unoidl-write_test \
+ $(if $(filter ODK,$(BUILD_TYPE)),CustomTarget_unoidl-check_test) \
+))
+# vim: set noet sw=4 ts=4: