summaryrefslogtreecommitdiffstats
path: root/unoil/CustomTarget_javamaker.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /unoil/CustomTarget_javamaker.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'unoil/CustomTarget_javamaker.mk')
-rw-r--r--unoil/CustomTarget_javamaker.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/unoil/CustomTarget_javamaker.mk b/unoil/CustomTarget_javamaker.mk
new file mode 100644
index 0000000000..97793d5196
--- /dev/null
+++ b/unoil/CustomTarget_javamaker.mk
@@ -0,0 +1,31 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,unoil/javamaker))
+
+unoil_JAVADIR := $(call gb_CustomTarget_get_workdir,unoil/javamaker)
+
+$(call gb_CustomTarget_get_target,unoil/javamaker) : $(unoil_JAVADIR)/done
+
+$(unoil_JAVADIR)/done : \
+ $(call gb_UnoApi_get_target,offapi) \
+ $(call gb_UnoApi_get_target,udkapi) \
+ $(call gb_Executable_get_runtime_dependencies,javamaker) \
+ | $(unoil_JAVADIR)/.dir
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),JVM,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),JVM)
+ $(call gb_Helper_abbreviate_dirs, \
+ rm -r $(unoil_JAVADIR) && \
+ $(call gb_Helper_execute,javamaker -O$(unoil_JAVADIR) \
+ $(call gb_UnoApi_get_target,offapi) \
+ -X$(call gb_UnoApi_get_target,udkapi)) && \
+ touch $@)
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),JVM)
+
+# vim:set shiftwidth=4 tabstop=4 noexpandtab: