summaryrefslogtreecommitdiffstats
path: root/unotest/Module_unotest.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /unotest/Module_unotest.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'unotest/Module_unotest.mk')
-rw-r--r--unotest/Module_unotest.mk35
1 files changed, 35 insertions, 0 deletions
diff --git a/unotest/Module_unotest.mk b/unotest/Module_unotest.mk
new file mode 100644
index 0000000000..bdffe8e8ac
--- /dev/null
+++ b/unotest/Module_unotest.mk
@@ -0,0 +1,35 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,unotest))
+
+ifeq ($(gb_Side),host)
+ifneq (,$(filter DESKTOP,$(BUILD_TYPE)))
+$(eval $(call gb_Module_add_targets,unotest,\
+ Library_unobootstrapprotector \
+ Library_unoexceptionprotector \
+ Library_unotest \
+))
+endif
+
+ifneq ($(ENABLE_JAVA),)
+$(eval $(call gb_Module_add_targets,unotest,\
+ Jar_test-tools \
+))
+
+ifneq ($(OOO_JUNIT_JAR),)
+$(eval $(call gb_Module_add_targets,unotest,\
+ Jar_test \
+))
+endif
+endif
+endif
+
+# vim: set noet sw=4 ts=4: