summaryrefslogtreecommitdiffstats
path: root/vcl/CustomTarget_kf6_moc.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /vcl/CustomTarget_kf6_moc.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vcl/CustomTarget_kf6_moc.mk')
-rw-r--r--vcl/CustomTarget_kf6_moc.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/vcl/CustomTarget_kf6_moc.mk b/vcl/CustomTarget_kf6_moc.mk
new file mode 100644
index 0000000000..ba0f514cd8
--- /dev/null
+++ b/vcl/CustomTarget_kf6_moc.mk
@@ -0,0 +1,29 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,vcl/unx/kf6))
+
+$(call gb_CustomTarget_get_target,vcl/unx/kf6) : \
+ $(call gb_CustomTarget_get_workdir,vcl/unx/kf6)/KFFilePicker.moc
+
+# For now, the headers in vcl/unx/kf6 just '#include' the ones
+# in 'vcl/unx/kf5'.
+# Since moc does not process classes from the included headers,
+# it needs to be run on the headers in the kf5 dir.
+# That will have to be adapted in case the kf6 VCL plugin
+# uses "own" headers
+$(call gb_CustomTarget_get_workdir,vcl/unx/kf6)/%.moc : \
+ $(SRCDIR)/vcl/unx/kf5/%.hxx \
+ | $(call gb_CustomTarget_get_workdir,vcl/unx/kf6)/.dir
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),MOC,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),MOC)
+ $(MOC6) $< -o $@
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),MOC)
+
+# vim: set noet sw=4: