summaryrefslogtreecommitdiffstats
path: root/winaccessibility/CustomTarget_ia2_idl.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /winaccessibility/CustomTarget_ia2_idl.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'winaccessibility/CustomTarget_ia2_idl.mk')
-rw-r--r--winaccessibility/CustomTarget_ia2_idl.mk60
1 files changed, 60 insertions, 0 deletions
diff --git a/winaccessibility/CustomTarget_ia2_idl.mk b/winaccessibility/CustomTarget_ia2_idl.mk
new file mode 100644
index 0000000000..364e6b6257
--- /dev/null
+++ b/winaccessibility/CustomTarget_ia2_idl.mk
@@ -0,0 +1,60 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,winaccessibility/ia2/idl))
+
+iaccessible2_DIR := $(call gb_UnpackedTarball_get_dir,IAccessible2)
+wina11y_COMIDLDIR := $(call gb_CustomTarget_get_workdir,winaccessibility/ia2/idl)
+wina11y_SOURCE := $(SRCDIR)/winaccessibility/source/UAccCOMIDL
+
+# We cannot depend on *.tlb because they only produced by IDL compiler
+# if idl contains 'library' statement.
+$(call gb_CustomTarget_get_target,winaccessibility/ia2/idl) : \
+ $(wina11y_COMIDLDIR)/UAccCOM.h \
+ $(wina11y_COMIDLDIR)/defines.h \
+ $(wina11y_COMIDLDIR)/ia2_api_all.h
+
+$(wina11y_COMIDLDIR)/ia2_api_all.h: $(call gb_ExternalProject_get_target,IAccessible2) \
+ | $(wina11y_COMIDLDIR)/.dir
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),IDL,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),IDL)
+ $(call gb_Helper_abbreviate_dirs, \
+ midl.exe \
+ -tlb $(wina11y_COMIDLDIR)/ia2_api_all.tlb \
+ -h $(wina11y_COMIDLDIR)/ia2_api_all.h \
+ -iid $(wina11y_COMIDLDIR)/ia2_api_all_i.c \
+ -dlldata $(wina11y_COMIDLDIR)/dlldata.c \
+ -proxy $(wina11y_COMIDLDIR)/ia2_api_all_p.c \
+ -Oicf \
+ $(SOLARINC) \
+ -I $(wina11y_SOURCE) \
+ -I $(iaccessible2_DIR) \
+ $(iaccessible2_DIR)/ia2_api_all.idl)
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),IDL)
+
+$(wina11y_COMIDLDIR)/%.h : $(wina11y_SOURCE)/%.idl \
+ $(call gb_ExternalProject_get_target,IAccessible2) \
+ | $(wina11y_COMIDLDIR)/.dir
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),IDL,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),IDL)
+ $(call gb_Helper_abbreviate_dirs, \
+ midl.exe \
+ -tlb $(wina11y_COMIDLDIR)/$*.tlb \
+ -h $(wina11y_COMIDLDIR)/$*.h \
+ -iid $(wina11y_COMIDLDIR)/$*_i.c \
+ -dlldata $(wina11y_COMIDLDIR)/dlldata.c \
+ -proxy $(wina11y_COMIDLDIR)/$*_p.c \
+ -Oicf \
+ $(SOLARINC) \
+ -I $(wina11y_SOURCE) \
+ -I $(iaccessible2_DIR) \
+ $<)
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),IDL)
+
+# vim:set shiftwidth=4 tabstop=4 noexpandtab: