summaryrefslogtreecommitdiffstats
path: root/xmloff/CustomTarget_generated.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /xmloff/CustomTarget_generated.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'xmloff/CustomTarget_generated.mk')
-rw-r--r--xmloff/CustomTarget_generated.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/xmloff/CustomTarget_generated.mk b/xmloff/CustomTarget_generated.mk
new file mode 100644
index 0000000000..fe135c2b37
--- /dev/null
+++ b/xmloff/CustomTarget_generated.mk
@@ -0,0 +1,26 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,xmloff/generated))
+
+#Generates a hashtable for the odf-tags
+xmloff_SRC := $(SRCDIR)/xmloff/source/token
+xmloff_MISC := $(call gb_CustomTarget_get_workdir,xmloff/generated)/misc
+xmloff_INC := $(call gb_CustomTarget_get_workdir,xmloff/generated)
+xmloff_GENHEADERPATH := $(xmloff_INC)/xmloff/token
+
+$(eval $(call gb_CustomTarget_token_hash,xmloff/generated,tokenhash.inc,tokenhash.gperf))
+$(eval $(call gb_CustomTarget_generate_tokens,xmloff/generated,xmloff,xmloff/source/token,tokens,token,tokenhash.gperf))
+
+$(call gb_CustomTarget_get_target,xmloff/generated) : \
+ $(xmloff_INC)/tokenhash.inc \
+ $(xmloff_INC)/tokennames.inc \
+ $(xmloff_GENHEADERPATH)/tokens.hxx \
+
+# vim: set noet sw=4 ts=4: