summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog12
-rw-r--r--debian/control4
-rw-r--r--debian/control.in4
-rwxr-xr-xdebian/rules13
4 files changed, 25 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 1b8a22b171..826fe2d4e0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,17 @@
+libreoffice (4:24.2.2-3) unstable; urgency=medium
+
+ * debian/rules: make -commons -mysql and -firebird Breaks: << 4:24.2.2-2~
+ to fix it in backports
+ * debian/rules: guard firebird_sdbc.xcu install in install-common;
+ only try if it exists (as the qt/kde stuff) and add comment to the
+ build-indep check why
+
+ -- Rene Engelhard <rene@debian.org> Sun, 31 Mar 2024 12:25:17 +0200
+
libreoffice (4:24.2.2-2) unstable; urgency=medium
* debian/patches/split-sdbc-firebird-mariadb.diff: create extra
- {mysqlc,firebird_sdbc}.xcd add as for evoab. Otherwise configuration
+ {mysqlc,firebird_sdbc}.xcd as for evoab. Otherwise configuration
parts of it ends up (or not in indep builds) in libreoffice-commons
main.xcd
* debian/rules:
diff --git a/debian/control b/debian/control
index 7e94603cef..8153e1251e 100644
--- a/debian/control
+++ b/debian/control
@@ -605,8 +605,8 @@ Breaks: libreoffice-base (<< 1:6.4.0~beta1-2~),
libreoffice-l10n (<< 7.0),
libreoffice-librelogo (<< 1:7.0.0~alpha),
libreoffice-report-builder (<< 1:7.0.0~alpha),
- libreoffice-sdbc-firebird (<< 4:24.2.2-2),
- libreoffice-sdbc-mysql (<< 4:24.2.2-2),
+ libreoffice-sdbc-firebird (<< 4:24.2.2-2~),
+ libreoffice-sdbc-mysql (<< 4:24.2.2-2~),
libreoffice-sdbc-postgresql (<< 1:7.0.0~alpha),
libreoffice-style-andromeda (<< 4:${oover}~),
libreoffice-style-crystal (<< 4:${oover}~),
diff --git a/debian/control.in b/debian/control.in
index 187304e377..da6bc5132b 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -337,8 +337,8 @@ Breaks: libreoffice-core (<< 4:${oover}~),
libreoffice-l10n (<< 7.0),
libreoffice-librelogo (<< 1:7.0.0~alpha),
libreoffice-sdbc-postgresql (<< 1:7.0.0~alpha),
- libreoffice-sdbc-mysql (<< 4:24.2.2-2),
- libreoffice-sdbc-firebird (<< 4:24.2.2-2),
+ libreoffice-sdbc-mysql (<< 4:24.2.2-2~),
+ libreoffice-sdbc-firebird (<< 4:24.2.2-2~),
libreoffice-report-builder (<< 1:7.0.0~alpha),
libreoffice-evolution (<< 1:7.0.0~alpha),
libreoffice-gnome (<< 1:7.0.0~alpha),
diff --git a/debian/rules b/debian/rules
index ba8e24374f..aaad22edce 100755
--- a/debian/rules
+++ b/debian/rules
@@ -463,6 +463,11 @@ SYSTEM_STUFF += frozen
SYSTEM_STUFF += argon2
# override stuff for build-indep to save build dependencies
+# This is a hack. dpkg calls build-indep for -A so this is in effect.
+# but for the binary target it calls binary-indep which calls install etc
+# apparently without these. so those guards do not work if stuff is moved
+# in install-common. e.g. qt/kf5, firebird_sdbc.xcd. Those need to be guarded
+# with an if [ -f or similar
ifeq ($(MAKECMDGOALS),build-indep)
ENABLE_EVOAB=n
BUILD_GTK3=n
@@ -2948,9 +2953,11 @@ ifeq "$(ENABLE_JAVA)" "y"
endif
ifeq "$(ENABLE_FIREBIRD)" "y"
- mkdir -p $(PKGDIR)-sdbc-firebird/$(OODIR)/share/registry
- mv $(PKGDIR)-common/$(OODIR)/share/registry/firebird_sdbc.xcd \
- $(PKGDIR)-sdbc-firebird/$(OODIR)/share/registry
+ if [ -f $(PKGDIR)-common/$(OODIR)/share/registry/firebird_sdbc.xcd ]; then \
+ mkdir -p $(PKGDIR)-sdbc-firebird/$(OODIR)/share/registry; \
+ mv $(PKGDIR)-common/$(OODIR)/share/registry/firebird_sdbc.xcd \
+ $(PKGDIR)-sdbc-firebird/$(OODIR)/share/registry; \
+ fi
endif
ifeq "$(PACKAGE_SDK)" "y"