summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules58
1 files changed, 40 insertions, 18 deletions
diff --git a/debian/rules b/debian/rules
index b43cc79c3c..346905ec1f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -206,27 +206,33 @@ ifeq "$(ENABLE_GUI)" "y"
BUILD_PLASMA=y
# let's assume we won't ship two plasmas parallel..
PLASMA_VERSION=5
+PLASMA_KF_VERSION=$(PLASMA_VERSION)
ENABLE_QT5=n
#QT5_MINVER=
+ENABLE_KF5=y
+ENABLE_QT6=y
+ENABLE_KF6=n
endif
+# go sure. if we want plasma, we want kfX, too and if we want that
+# one we want qtX, too.
ifeq "$(BUILD_PLASMA)" "y"
ifeq "$(PLASMA_VERSION)" "5"
ENABLE_KF5=y
- # KF5 depends on Qt5
- ifeq "$(ENABLE_KF5)" "y"
- ENABLE_QT5=y
- KF5_QT5_DEPENDS := libreoffice-qt5 (= $${binary:Version})
- endif
- else
+ endif
+ ifeq "$(PLASMA_VERSION)" "6"
ENABLE_KF6=y
- # KF6 depends on Qt6
- ifeq "$(ENABLE_KF6)" "y"
- ENABLE_QT6=y
- KF6_QT6_DEPENDS := libreoffice-qt6 (= $${binary:Version})
- endif
endif
endif
-ENABLE_QT6=y
+# KF5 depends on Qt5
+ifeq "$(ENABLE_KF5)" "y"
+ ENABLE_QT5=y
+ KF5_QT5_DEPENDS := libreoffice-qt5 (= $${binary:Version})
+endif
+# KF6 depends on Qt6
+ifeq "$(ENABLE_KF6)" "y"
+ ENABLE_QT6=y
+ KF6_QT6_DEPENDS := libreoffice-qt6 (= $${binary:Version})
+endif
# https://www.debian.org/doc/debian-policy/ says this is not defined and must
# be ignored, but dh_strip mentions (and honours) it, so...
ifneq (noautodbgsym,$(findstring noautodbgsym,$(DEB_BUILD_OPTIONS)))
@@ -619,7 +625,7 @@ OOO_CHECK_FATAL_ARCHS += armhf
OOO_SMOKETEST_FATAL_ARCHS := $(OOO_ARCHS)
# archs where the archive/ci runs autopkgtests
-OOO_AUTOPKGTEST_ARCHS := $(OOO_CHECK_ARCHS) i386 ppc64el s390x
+OOO_AUTOPKGTEST_ARCHS := $(OOO_CHECK_ARCHS) armel i386 ppc64el s390x riscv64
ifeq (alpha,$(findstring $(DEB_HOST_ARCH),$(OOO_ARCHS)))
PACKAGE_GEN=n
@@ -2185,7 +2191,13 @@ ifeq "$(ENABLE_QT6)" "y"
endif
ifeq "$(BUILD_PLASMA)" "y"
sed -e "s|@PLASMA_VERSION@|$(PLASMA_VERSION)|g" \
+ -e "s|@PLASMA_KF_VERSION@|$(PLASMA_KF_VERSION)|g" \
>> debian/control.new < debian/control.plasma.in
+ # no kf6be here
+ifeq "$(PLASMA_VERSION)" "6"
+ sed -i "s/and a KDE\/KF$(PLASMA_KF_VERSION) configuration backend//" \
+ debian/control.new
+endif
endif
cat debian/control.postgresql.in >> debian/control.new
ifeq "$(ENABLE_EVO2)" "y"
@@ -2220,6 +2232,14 @@ else
perl -pi -e 's/%LO-DESKTOP-INTEGRATION%/libreoffice-gnome/' debian/control.new
endif
+ifeq "$(ENABLE_KF5)" "y"
+ifneq "$(BOOKWORM_BACKPORT)" "y"
+ perl -pi -e 's/plasma-iconset-dep}/plasma-iconset-dep}, kio (>> 5.115.0-5)/' debian/control.new
+else
+ perl -pi -e 's/plasma-iconset-dep}/plasma-iconset-dep}, kio (>> 5.103.0-1)' debian/control.new
+endif
+endif
+
ifeq (sk,$(findstring sk,$(HELPISOS)))
perl -pi -e 's/(Depends:.*)libreoffice-l10n-sk(.*)$$/\1libreoffice-l10n-sk, libreoffice-help-cs\2/' debian/control.new
endif
@@ -2678,13 +2698,15 @@ ifeq "$(ENABLE_QT6)" "y"
endif
ifeq "$(shell echo $(ENABLE_KF5)$(ENABLE_KF6) | grep -q y && echo true)" "true"
ifeq "$(BUILD_PLASMA)" "y"
- mkdir -p debian/tmp/pkg/libreoffice-plasma/$(OODIR)/program
- mv debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libkf$(PLASMA_VERSION)be1lo.so \
- debian/tmp/pkg/libreoffice-plasma/$(OODIR)/program
+ if [ -f debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libkf$(PLASMA_VERSION)be1lo.so ]; then \
+ mkdir -p debian/tmp/pkg/libreoffice-plasma/$(OODIR)/program; \
+ mv debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libkf$(PLASMA_VERSION)be1lo.so \
+ debian/tmp/pkg/libreoffice-plasma/$(OODIR)/program; \
+ fi
# remove other ones maybe built by --enable-kfX
- rm -f debian/tmp/pkg/libreoffice-kde/$(OODIR)/libkf*be1lo.so
+ rm -f debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libkf*be1lo.so
else
- rm -f debian/tmp/pkg/libreoffice-kde/$(OODIR)/libkf*be1lo.so
+ rm -f debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libkf*be1lo.so
endif
ifeq "$(ENABLE_KF5)" "y"
mkdir -p debian/tmp/pkg/libreoffice-kf5/$(OODIR)/program