summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 10 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index ba8e24374f..aaad22edce 100755
--- a/debian/rules
+++ b/debian/rules
@@ -463,6 +463,11 @@ SYSTEM_STUFF += frozen
SYSTEM_STUFF += argon2
# override stuff for build-indep to save build dependencies
+# This is a hack. dpkg calls build-indep for -A so this is in effect.
+# but for the binary target it calls binary-indep which calls install etc
+# apparently without these. so those guards do not work if stuff is moved
+# in install-common. e.g. qt/kf5, firebird_sdbc.xcd. Those need to be guarded
+# with an if [ -f or similar
ifeq ($(MAKECMDGOALS),build-indep)
ENABLE_EVOAB=n
BUILD_GTK3=n
@@ -2948,9 +2953,11 @@ ifeq "$(ENABLE_JAVA)" "y"
endif
ifeq "$(ENABLE_FIREBIRD)" "y"
- mkdir -p $(PKGDIR)-sdbc-firebird/$(OODIR)/share/registry
- mv $(PKGDIR)-common/$(OODIR)/share/registry/firebird_sdbc.xcd \
- $(PKGDIR)-sdbc-firebird/$(OODIR)/share/registry
+ if [ -f $(PKGDIR)-common/$(OODIR)/share/registry/firebird_sdbc.xcd ]; then \
+ mkdir -p $(PKGDIR)-sdbc-firebird/$(OODIR)/share/registry; \
+ mv $(PKGDIR)-common/$(OODIR)/share/registry/firebird_sdbc.xcd \
+ $(PKGDIR)-sdbc-firebird/$(OODIR)/share/registry; \
+ fi
endif
ifeq "$(PACKAGE_SDK)" "y"