summaryrefslogtreecommitdiffstats
path: root/external/cppunit/UnpackedTarball_cppunit.mk
diff options
context:
space:
mode:
Diffstat (limited to 'external/cppunit/UnpackedTarball_cppunit.mk')
-rw-r--r--external/cppunit/UnpackedTarball_cppunit.mk44
1 files changed, 44 insertions, 0 deletions
diff --git a/external/cppunit/UnpackedTarball_cppunit.mk b/external/cppunit/UnpackedTarball_cppunit.mk
new file mode 100644
index 0000000000..99bbea6971
--- /dev/null
+++ b/external/cppunit/UnpackedTarball_cppunit.mk
@@ -0,0 +1,44 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_UnpackedTarball_UnpackedTarball,cppunit))
+
+$(eval $(call gb_UnpackedTarball_set_tarball,cppunit,$(CPPUNIT_TARBALL),,cppunit))
+
+$(eval $(call gb_UnpackedTarball_update_autoconf_configs,cppunit))
+
+# * external/cppunit/order.patch.0 upstreamed at <https://gerrit.libreoffice.org/c/cppunit/+/123963>
+# "Run tests in deterministic order";
+# * external/cppunit/propagate-exceptions.patch.0 upstreamed at
+# <https://gerrit.libreoffice.org/c/cppunit/+/144074> "Introduce CPPUNIT_PROPAGATE_EXCEPTIONS
+# environment variable";
+# * external/cppunit/sprintf.patch.0 upstreamed at
+# <https://gerrit.libreoffice.org/c/cppunit/+/147383> "Use snprintf instead of sprintf";
+# * external/cppunit/clang.patch.0 upstreamed at
+# <https://gerrit.libreoffice.org/c/cppunit/+/147384> "Don't mis-apply GCC < 4.6 workaround for
+# Clang":
+$(eval $(call gb_UnpackedTarball_add_patches,cppunit,\
+ external/cppunit/windows.patch \
+ external/cppunit/unix.patch \
+ external/cppunit/CPPUNIT_PLUGIN_EXPORT.patch.0 \
+ external/cppunit/enable-win32-debug.patch \
+ external/cppunit/rtti.patch.0 \
+ external/cppunit/order.patch.0 \
+ external/cppunit/windows-arm64.patch.1 \
+ external/cppunit/propagate-exceptions.patch.0 \
+ external/cppunit/sprintf.patch.0 \
+ external/cppunit/clang.patch.0 \
+))
+ifeq ($(DISABLE_DYNLOADING),TRUE)
+$(eval $(call gb_UnpackedTarball_add_patches,cppunit,\
+ external/cppunit/disable-dynloading.patch \
+))
+endif
+
+# vim: set noet sw=4 ts=4: