summaryrefslogtreecommitdiffstats
path: root/external/lxml/replace-setuptools-with-distutils.patch.1
diff options
context:
space:
mode:
Diffstat (limited to 'external/lxml/replace-setuptools-with-distutils.patch.1')
-rw-r--r--external/lxml/replace-setuptools-with-distutils.patch.129
1 files changed, 29 insertions, 0 deletions
diff --git a/external/lxml/replace-setuptools-with-distutils.patch.1 b/external/lxml/replace-setuptools-with-distutils.patch.1
new file mode 100644
index 0000000000..5275e40312
--- /dev/null
+++ b/external/lxml/replace-setuptools-with-distutils.patch.1
@@ -0,0 +1,29 @@
+diff -ur lxml.org/setupinfo.py lxml/setupinfo.py
+--- lxml.org/setupinfo.py 2023-10-20 10:32:17.921500435 +0200
++++ lxml/setupinfo.py 2023-10-20 10:33:40.303323572 +0200
+@@ -4,7 +4,7 @@
+ import os.path
+ import subprocess
+
+-from setuptools.command.build_ext import build_ext as _build_ext
++from distutils.command.build_ext import build_ext as _build_ext
+ from distutils.core import Extension
+ from distutils.errors import CompileError, DistutilsOptionError
+ from versioninfo import get_base_dir
+diff -ur lxml.org/setup.py lxml/setup.py
+--- lxml.org/setup.py 2023-10-20 10:32:17.949501053 +0200
++++ lxml/setup.py 2023-10-20 10:33:09.082631759 +0200
+@@ -217,9 +217,10 @@
+ # `Unknown distribution option: 'bugtrack_url'`
+ # which distract folks from real causes of problems when troubleshooting
+ # bugtrack_url="https://bugs.launchpad.net/lxml",
+- project_urls={
+- "Source": "https://github.com/lxml/lxml",
+- },
++ # same as for bugtrack_urls also for project_urls when using distutils instead of setuptools
++ #project_urls={
++ # "Source": "https://github.com/lxml/lxml",
++ #},
+ description=(
+ "Powerful and Pythonic XML processing library"
+ " combining libxml2/libxslt with the ElementTree API."