summaryrefslogtreecommitdiffstats
path: root/external/onlineupdate/Executable_mbsdiff.mk
diff options
context:
space:
mode:
Diffstat (limited to 'external/onlineupdate/Executable_mbsdiff.mk')
-rw-r--r--external/onlineupdate/Executable_mbsdiff.mk43
1 files changed, 43 insertions, 0 deletions
diff --git a/external/onlineupdate/Executable_mbsdiff.mk b/external/onlineupdate/Executable_mbsdiff.mk
new file mode 100644
index 0000000000..a417299095
--- /dev/null
+++ b/external/onlineupdate/Executable_mbsdiff.mk
@@ -0,0 +1,43 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,mbsdiff))
+
+$(eval $(call gb_Executable_use_unpacked,mbsdiff,onlineupdate))
+
+$(eval $(call gb_Executable_set_include,mbsdiff,\
+ -I$(call gb_UnpackedTarball_get_dir,onlineupdate)/onlineupdate/inc \
+ -I$(call gb_UnpackedTarball_get_dir,onlineupdate)/toolkit/mozapps/update/updater \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Executable_use_externals,mbsdiff,\
+ bzip2 \
+))
+
+
+ifeq ($(OS),WNT)
+
+$(eval $(call gb_Executable_add_defs,mbsdiff, \
+ -DXP_WIN \
+))
+
+$(eval $(call gb_Executable_add_libs,mbsdiff,\
+ ws2_32.lib \
+))
+
+endif
+
+$(eval $(call gb_Executable_add_generated_cobjects,mbsdiff,\
+ UnpackedTarball/onlineupdate/onlineupdate/source/mbsdiff/bsdiff \
+))
+
+$(eval $(call gb_Executable_set_warnings_disabled,mbsdiff))
+
+# vim:set shiftwidth=4 tabstop=4 noexpandtab: */