summaryrefslogtreecommitdiffstats
path: root/external/zxing/UnpackedTarball_zxing.mk
diff options
context:
space:
mode:
Diffstat (limited to 'external/zxing/UnpackedTarball_zxing.mk')
-rw-r--r--external/zxing/UnpackedTarball_zxing.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/external/zxing/UnpackedTarball_zxing.mk b/external/zxing/UnpackedTarball_zxing.mk
new file mode 100644
index 0000000000..0a81505463
--- /dev/null
+++ b/external/zxing/UnpackedTarball_zxing.mk
@@ -0,0 +1,22 @@
+#-*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_UnpackedTarball_UnpackedTarball,zxing))
+
+$(eval $(call gb_UnpackedTarball_set_tarball,zxing,$(ZXING_TARBALL)))
+
+$(eval $(call gb_UnpackedTarball_set_patchlevel,zxing,1))
+
+# patch 0001-android-Fix-build-with-NDK-26.patch is backport of
+# upstream commit https://github.com/zxing-cpp/zxing-cpp/commit/295b193b0105e68bb24747aefbff2653df892b4c
+$(eval $(call gb_UnpackedTarball_add_patches,zxing, \
+ external/zxing/0001-android-Fix-build-with-NDK-26.patch \
+))
+
+# vim: set noet sw=4 ts=4: