summaryrefslogtreecommitdiffstats
path: root/lingucomponent/StaticLibrary_ulingu.mk
diff options
context:
space:
mode:
Diffstat (limited to 'lingucomponent/StaticLibrary_ulingu.mk')
-rw-r--r--lingucomponent/StaticLibrary_ulingu.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/lingucomponent/StaticLibrary_ulingu.mk b/lingucomponent/StaticLibrary_ulingu.mk
new file mode 100644
index 0000000000..1bee43eeb1
--- /dev/null
+++ b/lingucomponent/StaticLibrary_ulingu.mk
@@ -0,0 +1,34 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_StaticLibrary_StaticLibrary,ulingu))
+
+$(eval $(call gb_StaticLibrary_use_api,ulingu,\
+ udkapi \
+ offapi \
+))
+
+ifneq ($(SYSTEM_DICTS),)
+$(eval $(call gb_StaticLibrary_add_defs,ulingu,\
+ -DSYSTEM_DICTS -DDICT_SYSTEM_DIR=\"$(DICT_SYSTEM_DIR)\" -DHYPH_SYSTEM_DIR=\"$(HYPH_SYSTEM_DIR)\" -DTHES_SYSTEM_DIR=\"$(THES_SYSTEM_DIR)\" \
+))
+
+endif
+
+$(eval $(call gb_StaticLibrary_use_externals,ulingu,\
+ boost_headers \
+ hunspell \
+))
+
+$(eval $(call gb_StaticLibrary_add_exception_objects,ulingu,\
+ lingucomponent/source/lingutil/lingutil \
+))
+
+# vim: set noet sw=4 ts=4: