summaryrefslogtreecommitdiffstats
path: root/test
diff options
context:
space:
mode:
Diffstat (limited to 'test')
-rw-r--r--test/CppunitTest_test_a11y.mk1
-rw-r--r--test/source/xmltesttools.cxx2
2 files changed, 3 insertions, 0 deletions
diff --git a/test/CppunitTest_test_a11y.mk b/test/CppunitTest_test_a11y.mk
index 22d1c8bc55..212e905978 100644
--- a/test/CppunitTest_test_a11y.mk
+++ b/test/CppunitTest_test_a11y.mk
@@ -14,6 +14,7 @@ $(eval $(call gb_CppunitTest_add_exception_objects,test_a11y, \
))
$(eval $(call gb_CppunitTest_use_libraries,test_a11y, \
+ acc \
sal \
cppu \
subsequenttest \
diff --git a/test/source/xmltesttools.cxx b/test/source/xmltesttools.cxx
index 14f953557f..eff0247c85 100644
--- a/test/source/xmltesttools.cxx
+++ b/test/source/xmltesttools.cxx
@@ -294,6 +294,8 @@ int XmlTestTools::getXPathPosition(const xmlDocUniquePtr& pXmlDoc, const OString
void XmlTestTools::registerODFNamespaces(xmlXPathContextPtr& pXmlXpathCtx)
{
+ xmlXPathRegisterNs(pXmlXpathCtx, BAD_CAST("manifest"),
+ BAD_CAST("urn:oasis:names:tc:opendocument:xmlns:manifest:1.0"));
xmlXPathRegisterNs(pXmlXpathCtx, BAD_CAST("office"),
BAD_CAST("urn:oasis:names:tc:opendocument:xmlns:office:1.0"));
xmlXPathRegisterNs(pXmlXpathCtx, BAD_CAST("style"),