summaryrefslogtreecommitdiffstats
path: root/debian/patches/python_single_version_externally_managed.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/python_single_version_externally_managed.patch')
-rw-r--r--debian/patches/python_single_version_externally_managed.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/debian/patches/python_single_version_externally_managed.patch b/debian/patches/python_single_version_externally_managed.patch
new file mode 100644
index 0000000..5e8be5b
--- /dev/null
+++ b/debian/patches/python_single_version_externally_managed.patch
@@ -0,0 +1,14 @@
+Fix building with setuptools instead of distutils.
+
+--- libseccomp-2.5.4.orig/src/python/Makefile.am
++++ libseccomp-2.5.4/src/python/Makefile.am
+@@ -40,7 +40,8 @@ build: ../libseccomp.la libseccomp.pxd s
+
+ install-exec-local: build
+ ${PY_INSTALL} --install-lib=${DESTDIR}/${pyexecdir} \
+- --record=${DESTDIR}/${pyexecdir}/install_files.txt
++ --record=${DESTDIR}/${pyexecdir}/install_files.txt \
++ --single-version-externally-managed
+
+ uninstall-local:
+ cat ${DESTDIR}/${pyexecdir}/install_files.txt | xargs ${RM} -f