summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--doc/Makefile.am54
1 files changed, 54 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..1e6eecc
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,54 @@
+####
+# Seccomp Library Documentation
+#
+
+#
+# This library is free software; you can redistribute it and/or modify it
+# under the terms of version 2.1 of the GNU Lesser General Public License
+# as published by the Free Software Foundation.
+#
+# This library is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser
+# General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with this library; if not, see <http://www.gnu.org/licenses>.
+#
+
+dist_man1_MANS = \
+ man/man1/scmp_sys_resolver.1
+
+dist_man3_MANS = \
+ man/man3/seccomp_arch_add.3 \
+ man/man3/seccomp_arch_exist.3 \
+ man/man3/seccomp_arch_native.3 \
+ man/man3/seccomp_arch_remove.3 \
+ man/man3/seccomp_arch_resolve_name.3 \
+ man/man3/seccomp_attr_get.3 \
+ man/man3/seccomp_attr_set.3 \
+ man/man3/seccomp_export_bpf.3 \
+ man/man3/seccomp_export_pfc.3 \
+ man/man3/seccomp_init.3 \
+ man/man3/seccomp_load.3 \
+ man/man3/seccomp_merge.3 \
+ man/man3/seccomp_release.3 \
+ man/man3/seccomp_reset.3 \
+ man/man3/seccomp_rule_add.3 \
+ man/man3/seccomp_rule_add_array.3 \
+ man/man3/seccomp_rule_add_exact.3 \
+ man/man3/seccomp_rule_add_exact_array.3 \
+ man/man3/seccomp_notify_alloc.3 \
+ man/man3/seccomp_notify_fd.3 \
+ man/man3/seccomp_notify_free.3 \
+ man/man3/seccomp_notify_id_valid.3 \
+ man/man3/seccomp_notify_receive.3 \
+ man/man3/seccomp_notify_respond.3 \
+ man/man3/seccomp_syscall_priority.3 \
+ man/man3/seccomp_syscall_resolve_name.3 \
+ man/man3/seccomp_syscall_resolve_name_arch.3 \
+ man/man3/seccomp_syscall_resolve_name_rewrite.3 \
+ man/man3/seccomp_syscall_resolve_num_arch.3 \
+ man/man3/seccomp_version.3 \
+ man/man3/seccomp_api_get.3 \
+ man/man3/seccomp_api_set.3