summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
commit75808db17caf8b960b351e3408e74142f4c85aac (patch)
tree7989e9c09a4240248bf4658a22208a0a52d991c4 /t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec
parentInitial commit. (diff)
downloadlintian-75808db17caf8b960b351e3408e74142f4c85aac.tar.xz
lintian-75808db17caf8b960b351e3408e74142f4c85aac.zip
Adding upstream version 2.117.0.upstream/2.117.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 't/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec')
-rw-r--r--t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec/debian/control.in15
-rw-r--r--t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec/fill-values3
-rw-r--r--t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec/orig/Makefile8
-rw-r--r--t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec/orig/script11
4 files changed, 27 insertions, 0 deletions
diff --git a/t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec/debian/control.in b/t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec/debian/control.in
new file mode 100644
index 0000000..d2ec26d
--- /dev/null
+++ b/t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec/debian/control.in
@@ -0,0 +1,15 @@
+Source: [% $source %]
+Priority: optional
+Section: devel
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: no
+
+Package: [% $source %]
+Architecture: [% $package_architecture %]
+Depends: ocaml-nox-3.10.2, ${shlib:Depends}, ${misc:Depends}
+Description: [% $description %]
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
diff --git a/t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec/fill-values b/t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec/fill-values
new file mode 100644
index 0000000..5e05c96
--- /dev/null
+++ b/t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: scripts-ocamlrun
+Description: Test correct handling of ocamlrun scripts
diff --git a/t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec/orig/Makefile b/t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec/orig/Makefile
new file mode 100644
index 0000000..54fa3ef
--- /dev/null
+++ b/t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec/orig/Makefile
@@ -0,0 +1,8 @@
+default:
+ :
+
+install:
+ install -d $(DESTDIR)/usr/bin
+ install -m755 script1 $(DESTDIR)/usr/bin/
+
+.PHONY: distclean realclean clean install test check
diff --git a/t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec/orig/script1 b/t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec/orig/script1
new file mode 100644
index 0000000..49c50f2
--- /dev/null
+++ b/t/recipes/checks/documentation/manual/scripts-ocamlrun/build-spec/orig/script1
@@ -0,0 +1 @@
+#!/usr/bin/ocamlrun