summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/files/hard-links/files-hardlinks/build-spec
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
commit75808db17caf8b960b351e3408e74142f4c85aac (patch)
tree7989e9c09a4240248bf4658a22208a0a52d991c4 /t/recipes/checks/files/hard-links/files-hardlinks/build-spec
parentInitial commit. (diff)
downloadlintian-75808db17caf8b960b351e3408e74142f4c85aac.tar.xz
lintian-75808db17caf8b960b351e3408e74142f4c85aac.zip
Adding upstream version 2.117.0.upstream/2.117.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 't/recipes/checks/files/hard-links/files-hardlinks/build-spec')
-rwxr-xr-xt/recipes/checks/files/hard-links/files-hardlinks/build-spec/debian/rules14
-rw-r--r--t/recipes/checks/files/hard-links/files-hardlinks/build-spec/fill-values3
2 files changed, 17 insertions, 0 deletions
diff --git a/t/recipes/checks/files/hard-links/files-hardlinks/build-spec/debian/rules b/t/recipes/checks/files/hard-links/files-hardlinks/build-spec/debian/rules
new file mode 100755
index 0000000..50f62ad
--- /dev/null
+++ b/t/recipes/checks/files/hard-links/files-hardlinks/build-spec/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+PKG:=files-hardlinks
+DIR:=$(CURDIR)/debian/$(PKG)/usr/share/$(PKG)
+
+%:
+ dh $@
+
+override_dh_install:
+ dh_install
+ mkdir -p $(DIR)/1st $(DIR)/2nd $(DIR)/3rd $(DIR)/4th
+ echo "Hallo world" > $(DIR)/3rd/orig
+ ln $(DIR)/3rd/orig $(DIR)/4th/link1
+ ln $(DIR)/4th/link1 $(DIR)/1st/link2
+ ln $(DIR)/3rd/orig $(DIR)/2nd/link3
diff --git a/t/recipes/checks/files/hard-links/files-hardlinks/build-spec/fill-values b/t/recipes/checks/files/hard-links/files-hardlinks/build-spec/fill-values
new file mode 100644
index 0000000..b5672c1
--- /dev/null
+++ b/t/recipes/checks/files/hard-links/files-hardlinks/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: files-hardlinks
+Description: Test for (stable) handling of hardlinks