summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/files/ieee-data/files-ieee-data/build-spec/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
commit75808db17caf8b960b351e3408e74142f4c85aac (patch)
tree7989e9c09a4240248bf4658a22208a0a52d991c4 /t/recipes/checks/files/ieee-data/files-ieee-data/build-spec/debian/rules
parentInitial commit. (diff)
downloadlintian-75808db17caf8b960b351e3408e74142f4c85aac.tar.xz
lintian-75808db17caf8b960b351e3408e74142f4c85aac.zip
Adding upstream version 2.117.0.upstream/2.117.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 't/recipes/checks/files/ieee-data/files-ieee-data/build-spec/debian/rules')
-rwxr-xr-xt/recipes/checks/files/ieee-data/files-ieee-data/build-spec/debian/rules23
1 files changed, 23 insertions, 0 deletions
diff --git a/t/recipes/checks/files/ieee-data/files-ieee-data/build-spec/debian/rules b/t/recipes/checks/files/ieee-data/files-ieee-data/build-spec/debian/rules
new file mode 100755
index 0000000..ecf629b
--- /dev/null
+++ b/t/recipes/checks/files/ieee-data/files-ieee-data/build-spec/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+PKG:=files-ieee-data
+INSTPATH:=$(CURDIR)/debian/tmp/usr/share/$(PKG)
+
+
+%:
+ dh $@
+
+override_dh_install:
+ mkdir -p $(INSTPATH)
+ gzip -c -n --best src/oui.txt > $(INSTPATH)/oui.txt.gz
+ cp src/oui.txt $(INSTPATH)/oui.idx
+ cp src/oui.txt $(INSTPATH)/oui.db
+ cp src/oui.txt $(INSTPATH)/iab.idx
+ cp src/oui.txt $(INSTPATH)/ieee-oui.idx
+ cp src/oui.txt $(INSTPATH)/get-iab
+ cp src/oui.txt $(INSTPATH)/download-oui
+# false positive
+ ln -s /usr/share/ieee-data/iab.txt $(INSTPATH)/iab.txt
+ dh_install
+
+
+