summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/apache2/apache2-webapplications-general
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/apache2/apache2-webapplications-general')
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/control.in48
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.dirs1
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.install1
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.postinst11
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.postrm12
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo2.dirs1
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo2.install3
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo3.dirs1
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo3.install1
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/fill-values3
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/false-positives.conf12
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/local-phpmyfoo2.conf1
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/phpmyfoo.conf14
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/phpmyfoo21
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/eval/desc2
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/eval/hints22
16 files changed, 134 insertions, 0 deletions
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/control.in b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/control.in
new file mode 100644
index 0000000..35a5386
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/control.in
@@ -0,0 +1,48 @@
+Source: [% $source %]
+Section: web
+Priority: optional
+Maintainer: Big Kahuna <kahuna@example.com>
+Uploaders: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: no
+
+Package: phpmyfoo
+Architecture: [% $package_architecture %]
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ apache2,
+ apache2-bin
+Description: [% $description %]
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+
+Package: phpmyfoo2
+Architecture: [% $package_architecture %]
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ apache2 | httpd
+Description: [% $description %] - ignore me
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Ignore me.
+
+Package: phpmyfoo3
+Architecture: [% $package_architecture %]
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ apache2 | lighttpd | httpd
+Description: [% $description %] - another ignore me
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Yet another ignore me.
+
+
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.dirs b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.dirs
new file mode 100644
index 0000000..31e10a9
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.dirs
@@ -0,0 +1 @@
+etc/apache2/conf-available
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.install b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.install
new file mode 100644
index 0000000..2789400
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.install
@@ -0,0 +1 @@
+phpmyfoo.conf /etc/apache2/conf-available
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.postinst b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.postinst
new file mode 100644
index 0000000..c4a1988
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.postinst
@@ -0,0 +1,11 @@
+#! /bin/sh
+
+set -e
+
+if [ "$1" = 'configure' ] ; then
+ a2enconf -q phpmyfoo
+fi
+
+invoke-rc.d apache2 reload
+
+#DEBHELPER#
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.postrm b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.postrm
new file mode 100644
index 0000000..d0db12e
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.postrm
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+set -e
+
+if [ "$1" = 'configure' ] ; then
+ a2disconf -q phpmyfoo
+fi
+
+invoke-rc.d apache2 reload
+
+#DEBHELPER#
+
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo2.dirs b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo2.dirs
new file mode 100644
index 0000000..31e10a9
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo2.dirs
@@ -0,0 +1 @@
+etc/apache2/conf-available
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo2.install b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo2.install
new file mode 100644
index 0000000..b2da1d6
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo2.install
@@ -0,0 +1,3 @@
+phpmyfoo2 /etc/apache2/conf-available
+local-phpmyfoo2.conf /etc/apache2/conf-available
+false-positives.conf /etc/apache2/conf-available
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo3.dirs b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo3.dirs
new file mode 100644
index 0000000..e9286b0
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo3.dirs
@@ -0,0 +1 @@
+etc/apache2/conf.d/
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo3.install b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo3.install
new file mode 100644
index 0000000..30fb624
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo3.install
@@ -0,0 +1 @@
+phpmyfoo.conf /etc/apache2/conf.d/
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/fill-values b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/fill-values
new file mode 100644
index 0000000..4bff8b5
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: apache2-webapplications-general
+Description: Several tests related to Apache2 web application packages
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/false-positives.conf b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/false-positives.conf
new file mode 100644
index 0000000..e54f470
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/false-positives.conf
@@ -0,0 +1,12 @@
+Alias /foo /usr/share/foo
+
+<Directory /usr/share/foo>
+ <IfModule !mod_authz_core.c>
+ Order deny, allow
+ Require valid-user
+ </IfModule>
+ <IfVersion < 2.3>
+ Order deny, allow
+ Require valid-user
+ </IfVersion>
+</Directory>
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/local-phpmyfoo2.conf b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/local-phpmyfoo2.conf
new file mode 100644
index 0000000..2cc691e
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/local-phpmyfoo2.conf
@@ -0,0 +1 @@
+<irrelevant>
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/phpmyfoo.conf b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/phpmyfoo.conf
new file mode 100644
index 0000000..1e3c4e3
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/phpmyfoo.conf
@@ -0,0 +1,14 @@
+# Depends: bar bar2.conf php7.0
+# Conflicts: notsupportedhere
+
+Alias /foo /usr/share/foo
+
+<Directory /usr/share/foo>
+ WebAppConf
+ <Limit POST PUT DELETE>
+ Order deny, allow
+ Require valid-user
+ </Limit>
+ AllowOverride None
+</Directory>
+
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/phpmyfoo2 b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/phpmyfoo2
new file mode 100644
index 0000000..2cc691e
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/phpmyfoo2
@@ -0,0 +1 @@
+<irrelevant>
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/eval/desc b/t/recipes/checks/apache2/apache2-webapplications-general/eval/desc
new file mode 100644
index 0000000..5769247
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/eval/desc
@@ -0,0 +1,2 @@
+Testname: apache2-webapplications-general
+Check: apache2
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/eval/hints b/t/recipes/checks/apache2/apache2-webapplications-general/eval/hints
new file mode 100644
index 0000000..6c17227
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/eval/hints
@@ -0,0 +1,22 @@
+phpmyfoo3 (binary): non-standard-apache2-configuration-name phpmyfoo.conf != phpmyfoo3.conf [etc/apache2/conf.d/phpmyfoo.conf]
+phpmyfoo3 (binary): apache2-unsupported-dependency Conflicts [etc/apache2/conf.d/phpmyfoo.conf:2]
+phpmyfoo3 (binary): apache2-unparsable-dependency bar2.conf [etc/apache2/conf.d/phpmyfoo.conf:1]
+phpmyfoo3 (binary): apache2-reverse-dependency-uses-obsolete-directory [etc/apache2/conf.d/phpmyfoo.conf]
+phpmyfoo3 (binary): apache2-deprecated-auth-config Order [etc/apache2/conf.d/phpmyfoo.conf:9]
+phpmyfoo3 (binary): apache2-deprecated-auth-config <Limit POST PUT DELETE> [etc/apache2/conf.d/phpmyfoo.conf:8]
+phpmyfoo3 (binary): apache2-deprecated-auth-config </Limit> [etc/apache2/conf.d/phpmyfoo.conf:11]
+phpmyfoo2 (binary): non-standard-apache2-configuration-name phpmyfoo2 != phpmyfoo2.conf [etc/apache2/conf-available/phpmyfoo2]
+phpmyfoo2 (binary): non-standard-apache2-configuration-name local-phpmyfoo2.conf != phpmyfoo2.conf [etc/apache2/conf-available/local-phpmyfoo2.conf]
+phpmyfoo2 (binary): non-standard-apache2-configuration-name false-positives.conf != phpmyfoo2.conf [etc/apache2/conf-available/false-positives.conf]
+phpmyfoo2 (binary): apache2-configuration-files-need-conf-suffix [etc/apache2/conf-available/phpmyfoo2]
+phpmyfoo (binary): web-application-works-only-with-apache phpmyfoo.conf [etc/apache2/conf-available/phpmyfoo.conf]
+phpmyfoo (binary): web-application-depends-on-apache2-data-package apache2-bin phpmyfoo.conf [etc/apache2/conf-available/phpmyfoo.conf]
+phpmyfoo (binary): apache2-unsupported-dependency Conflicts [etc/apache2/conf-available/phpmyfoo.conf:2]
+phpmyfoo (binary): apache2-unparsable-dependency bar2.conf [etc/apache2/conf-available/phpmyfoo.conf:1]
+phpmyfoo (binary): apache2-reverse-dependency-calls-wrapper-script a2enconf [postinst:6]
+phpmyfoo (binary): apache2-reverse-dependency-calls-wrapper-script a2disconf [postrm:6]
+phpmyfoo (binary): apache2-reverse-dependency-calls-invoke-rc.d [postrm:9]
+phpmyfoo (binary): apache2-reverse-dependency-calls-invoke-rc.d [postinst:9]
+phpmyfoo (binary): apache2-deprecated-auth-config Order [etc/apache2/conf-available/phpmyfoo.conf:9]
+phpmyfoo (binary): apache2-deprecated-auth-config <Limit POST PUT DELETE> [etc/apache2/conf-available/phpmyfoo.conf:8]
+phpmyfoo (binary): apache2-deprecated-auth-config </Limit> [etc/apache2/conf-available/phpmyfoo.conf:11]