summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/apache2
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/apache2')
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/control.in45
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo.dirs2
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo.install4
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo2.dirs2
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo2.install2
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo2.postinst9
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo2.postrm9
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-modbaz.dirs2
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-modbaz.install2
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/build-spec/fill-values3
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/Makefile5
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/baz.load1
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/foo1
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/foo.conf5
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/foo.load5
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/eval/desc2
-rw-r--r--t/recipes/checks/apache2/apache2-modules-general/eval/hints9
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/control.in48
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.dirs1
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.install1
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.postinst11
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.postrm12
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo2.dirs1
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo2.install3
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo3.dirs1
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo3.install1
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/fill-values3
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/false-positives.conf12
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/local-phpmyfoo2.conf1
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/phpmyfoo.conf14
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/phpmyfoo21
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/eval/desc2
-rw-r--r--t/recipes/checks/apache2/apache2-webapplications-general/eval/hints22
33 files changed, 242 insertions, 0 deletions
diff --git a/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/control.in b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/control.in
new file mode 100644
index 0000000..bebecc3
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/control.in
@@ -0,0 +1,45 @@
+Source: [% $source %]
+Section: httpd
+Priority: optional
+Maintainer: Big Kahuna <kahuna@example.com>
+Uploaders: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: no
+
+Package: libapache2-mod-foo
+Architecture: [% $package_architecture %]
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ apache2-api-19700101
+Description: [% $description %]
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+
+Package: libapache2-modbaz
+Architecture: [% $package_architecture %]
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ apache2.2-common,
+Description: [% $description %] don't care
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ To avoid duplicate description warnings this line differs. Ignore me.
+
+Package: libapache2-mod-foo2
+Architecture: [% $package_architecture %]
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ apache2-api-19700101,
+Description: [% $description %] still don't care
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ To avoid duplicate description warnings this line differs. Still ignore me.
diff --git a/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo.dirs b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo.dirs
new file mode 100644
index 0000000..871a471
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo.dirs
@@ -0,0 +1,2 @@
+etc/apache2/mods-available
+usr/lib/apache2/modules
diff --git a/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo.install b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo.install
new file mode 100644
index 0000000..ac8f7f1
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo.install
@@ -0,0 +1,4 @@
+foo.load /etc/apache2/mods-available
+foo /etc/apache2/mods-available
+foo.conf /etc/apache2/mods-available
+mod_foo.so /usr/lib/apache2/modules/
diff --git a/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo2.dirs b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo2.dirs
new file mode 100644
index 0000000..aec19ee
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo2.dirs
@@ -0,0 +1,2 @@
+etc/apache2/mods-enabled
+usr/lib/apache2/modules
diff --git a/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo2.install b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo2.install
new file mode 100644
index 0000000..8aab3d1
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo2.install
@@ -0,0 +1,2 @@
+foo.conf /etc/apache2/mods-enabled
+mod_foo2.so /usr/lib/apache2/modules/
diff --git a/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo2.postinst b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo2.postinst
new file mode 100644
index 0000000..8f6847d
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo2.postinst
@@ -0,0 +1,9 @@
+#! /bin/sh
+
+set -e
+
+if [ "$1" = 'configure' ] ; then
+ a2enmod -q foo2
+fi
+
+#DEBHELPER#
diff --git a/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo2.postrm b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo2.postrm
new file mode 100644
index 0000000..a4c83a6
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-mod-foo2.postrm
@@ -0,0 +1,9 @@
+#! /bin/sh
+
+set -e
+
+if [ "$1" = 'remove' ] ; then
+ a2dismod -q foo2
+fi
+
+#DEBHELPER#
diff --git a/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-modbaz.dirs b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-modbaz.dirs
new file mode 100644
index 0000000..871a471
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-modbaz.dirs
@@ -0,0 +1,2 @@
+etc/apache2/mods-available
+usr/lib/apache2/modules
diff --git a/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-modbaz.install b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-modbaz.install
new file mode 100644
index 0000000..5f2e1f9
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/build-spec/debian/libapache2-modbaz.install
@@ -0,0 +1,2 @@
+baz.load /etc/apache2/mods-available
+mod_baz.so /usr/lib/apache2/modules/
diff --git a/t/recipes/checks/apache2/apache2-modules-general/build-spec/fill-values b/t/recipes/checks/apache2/apache2-modules-general/build-spec/fill-values
new file mode 100644
index 0000000..608adaa
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: apache2-modules-general
+Description: Several tests related to Apache2 module packages
diff --git a/t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/Makefile b/t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/Makefile
new file mode 100644
index 0000000..4ce37c0
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/Makefile
@@ -0,0 +1,5 @@
+all:
+ touch mod_baz.so mod_foo2.so mod_foo.so
+
+clean:
+ rm -f *.so
diff --git a/t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/baz.load b/t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/baz.load
new file mode 100644
index 0000000..cb28fab
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/baz.load
@@ -0,0 +1 @@
+LoadModule baz_module /usr/lib/apache2/modules/mod_baz.so
diff --git a/t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/foo b/t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/foo
new file mode 100644
index 0000000..2cc691e
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/foo
@@ -0,0 +1 @@
+<irrelevant>
diff --git a/t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/foo.conf b/t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/foo.conf
new file mode 100644
index 0000000..bcbc503
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/foo.conf
@@ -0,0 +1,5 @@
+# Depends: notsupportedhere
+
+<Conf>
+ WithDirectives
+</Conf>
diff --git a/t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/foo.load b/t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/foo.load
new file mode 100644
index 0000000..7f1659f
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/build-spec/orig/foo.load
@@ -0,0 +1,5 @@
+# Depends: baz
+# Depends: baz baz2 mod_baz3 baz4.load
+# Conflicts: baz baz2
+
+LoadModule foo_module /usr/lib/apache2/modules/mod_foo.so
diff --git a/t/recipes/checks/apache2/apache2-modules-general/eval/desc b/t/recipes/checks/apache2/apache2-modules-general/eval/desc
new file mode 100644
index 0000000..673e5a3
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/eval/desc
@@ -0,0 +1,2 @@
+Testname: apache2-modules-general
+Check: apache2
diff --git a/t/recipes/checks/apache2/apache2-modules-general/eval/hints b/t/recipes/checks/apache2/apache2-modules-general/eval/hints
new file mode 100644
index 0000000..42c6401
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-modules-general/eval/hints
@@ -0,0 +1,9 @@
+libapache2-modbaz (binary): non-standard-apache2-module-package-name libapache2-modbaz != libapache2-mod-baz [usr/lib/apache2/modules/mod_baz.so]
+libapache2-modbaz (binary): apache2-module-does-not-depend-on-apache2-api [usr/lib/apache2/modules/mod_baz.so]
+libapache2-mod-foo2 (binary): apache2-reverse-dependency-ships-file-in-not-allowed-directory [etc/apache2/mods-enabled/foo.conf]
+libapache2-mod-foo2 (binary): apache2-reverse-dependency-calls-wrapper-script a2enmod [postinst:6]
+libapache2-mod-foo2 (binary): apache2-reverse-dependency-calls-wrapper-script a2dismod [postrm:6]
+libapache2-mod-foo2 (binary): apache2-module-does-not-ship-load-file etc/apache2/mods-available/foo2.load [usr/lib/apache2/modules/mod_foo2.so]
+libapache2-mod-foo (binary): apache2-unparsable-dependency mod_baz3 [etc/apache2/mods-available/foo.load:2]
+libapache2-mod-foo (binary): apache2-unparsable-dependency baz4.load [etc/apache2/mods-available/foo.load:2]
+libapache2-mod-foo (binary): apache2-configuration-files-need-conf-suffix [etc/apache2/mods-available/foo]
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/control.in b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/control.in
new file mode 100644
index 0000000..35a5386
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/control.in
@@ -0,0 +1,48 @@
+Source: [% $source %]
+Section: web
+Priority: optional
+Maintainer: Big Kahuna <kahuna@example.com>
+Uploaders: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: no
+
+Package: phpmyfoo
+Architecture: [% $package_architecture %]
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ apache2,
+ apache2-bin
+Description: [% $description %]
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+
+Package: phpmyfoo2
+Architecture: [% $package_architecture %]
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ apache2 | httpd
+Description: [% $description %] - ignore me
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Ignore me.
+
+Package: phpmyfoo3
+Architecture: [% $package_architecture %]
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ apache2 | lighttpd | httpd
+Description: [% $description %] - another ignore me
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Yet another ignore me.
+
+
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.dirs b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.dirs
new file mode 100644
index 0000000..31e10a9
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.dirs
@@ -0,0 +1 @@
+etc/apache2/conf-available
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.install b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.install
new file mode 100644
index 0000000..2789400
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.install
@@ -0,0 +1 @@
+phpmyfoo.conf /etc/apache2/conf-available
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.postinst b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.postinst
new file mode 100644
index 0000000..c4a1988
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.postinst
@@ -0,0 +1,11 @@
+#! /bin/sh
+
+set -e
+
+if [ "$1" = 'configure' ] ; then
+ a2enconf -q phpmyfoo
+fi
+
+invoke-rc.d apache2 reload
+
+#DEBHELPER#
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.postrm b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.postrm
new file mode 100644
index 0000000..d0db12e
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo.postrm
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+set -e
+
+if [ "$1" = 'configure' ] ; then
+ a2disconf -q phpmyfoo
+fi
+
+invoke-rc.d apache2 reload
+
+#DEBHELPER#
+
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo2.dirs b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo2.dirs
new file mode 100644
index 0000000..31e10a9
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo2.dirs
@@ -0,0 +1 @@
+etc/apache2/conf-available
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo2.install b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo2.install
new file mode 100644
index 0000000..b2da1d6
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo2.install
@@ -0,0 +1,3 @@
+phpmyfoo2 /etc/apache2/conf-available
+local-phpmyfoo2.conf /etc/apache2/conf-available
+false-positives.conf /etc/apache2/conf-available
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo3.dirs b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo3.dirs
new file mode 100644
index 0000000..e9286b0
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo3.dirs
@@ -0,0 +1 @@
+etc/apache2/conf.d/
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo3.install b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo3.install
new file mode 100644
index 0000000..30fb624
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/debian/phpmyfoo3.install
@@ -0,0 +1 @@
+phpmyfoo.conf /etc/apache2/conf.d/
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/fill-values b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/fill-values
new file mode 100644
index 0000000..4bff8b5
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: apache2-webapplications-general
+Description: Several tests related to Apache2 web application packages
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/false-positives.conf b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/false-positives.conf
new file mode 100644
index 0000000..e54f470
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/false-positives.conf
@@ -0,0 +1,12 @@
+Alias /foo /usr/share/foo
+
+<Directory /usr/share/foo>
+ <IfModule !mod_authz_core.c>
+ Order deny, allow
+ Require valid-user
+ </IfModule>
+ <IfVersion < 2.3>
+ Order deny, allow
+ Require valid-user
+ </IfVersion>
+</Directory>
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/local-phpmyfoo2.conf b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/local-phpmyfoo2.conf
new file mode 100644
index 0000000..2cc691e
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/local-phpmyfoo2.conf
@@ -0,0 +1 @@
+<irrelevant>
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/phpmyfoo.conf b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/phpmyfoo.conf
new file mode 100644
index 0000000..1e3c4e3
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/phpmyfoo.conf
@@ -0,0 +1,14 @@
+# Depends: bar bar2.conf php7.0
+# Conflicts: notsupportedhere
+
+Alias /foo /usr/share/foo
+
+<Directory /usr/share/foo>
+ WebAppConf
+ <Limit POST PUT DELETE>
+ Order deny, allow
+ Require valid-user
+ </Limit>
+ AllowOverride None
+</Directory>
+
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/phpmyfoo2 b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/phpmyfoo2
new file mode 100644
index 0000000..2cc691e
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/build-spec/orig/phpmyfoo2
@@ -0,0 +1 @@
+<irrelevant>
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/eval/desc b/t/recipes/checks/apache2/apache2-webapplications-general/eval/desc
new file mode 100644
index 0000000..5769247
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/eval/desc
@@ -0,0 +1,2 @@
+Testname: apache2-webapplications-general
+Check: apache2
diff --git a/t/recipes/checks/apache2/apache2-webapplications-general/eval/hints b/t/recipes/checks/apache2/apache2-webapplications-general/eval/hints
new file mode 100644
index 0000000..6c17227
--- /dev/null
+++ b/t/recipes/checks/apache2/apache2-webapplications-general/eval/hints
@@ -0,0 +1,22 @@
+phpmyfoo3 (binary): non-standard-apache2-configuration-name phpmyfoo.conf != phpmyfoo3.conf [etc/apache2/conf.d/phpmyfoo.conf]
+phpmyfoo3 (binary): apache2-unsupported-dependency Conflicts [etc/apache2/conf.d/phpmyfoo.conf:2]
+phpmyfoo3 (binary): apache2-unparsable-dependency bar2.conf [etc/apache2/conf.d/phpmyfoo.conf:1]
+phpmyfoo3 (binary): apache2-reverse-dependency-uses-obsolete-directory [etc/apache2/conf.d/phpmyfoo.conf]
+phpmyfoo3 (binary): apache2-deprecated-auth-config Order [etc/apache2/conf.d/phpmyfoo.conf:9]
+phpmyfoo3 (binary): apache2-deprecated-auth-config <Limit POST PUT DELETE> [etc/apache2/conf.d/phpmyfoo.conf:8]
+phpmyfoo3 (binary): apache2-deprecated-auth-config </Limit> [etc/apache2/conf.d/phpmyfoo.conf:11]
+phpmyfoo2 (binary): non-standard-apache2-configuration-name phpmyfoo2 != phpmyfoo2.conf [etc/apache2/conf-available/phpmyfoo2]
+phpmyfoo2 (binary): non-standard-apache2-configuration-name local-phpmyfoo2.conf != phpmyfoo2.conf [etc/apache2/conf-available/local-phpmyfoo2.conf]
+phpmyfoo2 (binary): non-standard-apache2-configuration-name false-positives.conf != phpmyfoo2.conf [etc/apache2/conf-available/false-positives.conf]
+phpmyfoo2 (binary): apache2-configuration-files-need-conf-suffix [etc/apache2/conf-available/phpmyfoo2]
+phpmyfoo (binary): web-application-works-only-with-apache phpmyfoo.conf [etc/apache2/conf-available/phpmyfoo.conf]
+phpmyfoo (binary): web-application-depends-on-apache2-data-package apache2-bin phpmyfoo.conf [etc/apache2/conf-available/phpmyfoo.conf]
+phpmyfoo (binary): apache2-unsupported-dependency Conflicts [etc/apache2/conf-available/phpmyfoo.conf:2]
+phpmyfoo (binary): apache2-unparsable-dependency bar2.conf [etc/apache2/conf-available/phpmyfoo.conf:1]
+phpmyfoo (binary): apache2-reverse-dependency-calls-wrapper-script a2enconf [postinst:6]
+phpmyfoo (binary): apache2-reverse-dependency-calls-wrapper-script a2disconf [postrm:6]
+phpmyfoo (binary): apache2-reverse-dependency-calls-invoke-rc.d [postrm:9]
+phpmyfoo (binary): apache2-reverse-dependency-calls-invoke-rc.d [postinst:9]
+phpmyfoo (binary): apache2-deprecated-auth-config Order [etc/apache2/conf-available/phpmyfoo.conf:9]
+phpmyfoo (binary): apache2-deprecated-auth-config <Limit POST PUT DELETE> [etc/apache2/conf-available/phpmyfoo.conf:8]
+phpmyfoo (binary): apache2-deprecated-auth-config </Limit> [etc/apache2/conf-available/phpmyfoo.conf:11]