summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/binaries/location/binaries-development-package-ships-elf-binary-in-path/build-spec/debian
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/binaries/location/binaries-development-package-ships-elf-binary-in-path/build-spec/debian')
-rw-r--r--t/recipes/checks/binaries/location/binaries-development-package-ships-elf-binary-in-path/build-spec/debian/compat.in1
-rw-r--r--t/recipes/checks/binaries/location/binaries-development-package-ships-elf-binary-in-path/build-spec/debian/control.in53
-rwxr-xr-xt/recipes/checks/binaries/location/binaries-development-package-ships-elf-binary-in-path/build-spec/debian/rules22
3 files changed, 76 insertions, 0 deletions
diff --git a/t/recipes/checks/binaries/location/binaries-development-package-ships-elf-binary-in-path/build-spec/debian/compat.in b/t/recipes/checks/binaries/location/binaries-development-package-ships-elf-binary-in-path/build-spec/debian/compat.in
new file mode 100644
index 0000000..640a566
--- /dev/null
+++ b/t/recipes/checks/binaries/location/binaries-development-package-ships-elf-binary-in-path/build-spec/debian/compat.in
@@ -0,0 +1 @@
+[% $dh_compat_level %]
diff --git a/t/recipes/checks/binaries/location/binaries-development-package-ships-elf-binary-in-path/build-spec/debian/control.in b/t/recipes/checks/binaries/location/binaries-development-package-ships-elf-binary-in-path/build-spec/debian/control.in
new file mode 100644
index 0000000..91b453f
--- /dev/null
+++ b/t/recipes/checks/binaries/location/binaries-development-package-ships-elf-binary-in-path/build-spec/debian/control.in
@@ -0,0 +1,53 @@
+Source: [% $source %]
+Priority: optional
+Section: libs
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: no
+
+Package: libmultiarch-none-dev
+Architecture: any
+Section: libdevel
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: [% $description %] (M-A: none)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ This package does not specify a Multi-Arch field.
+
+Package: libmultiarch-foreign-dev
+Architecture: any
+Section: libdevel
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Multi-Arch: foreign
+Description: [% $description %] (M-A: foreign)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ This package specifies Multi-Arch: foreign.
+
+Package: libmultiarch-same-dev
+Architecture: any
+Section: libdevel
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Multi-Arch: same
+Description: [% $description %] (M-A: same)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ This package specifies Multi-Arch: same.
+
+Package: libmultiarch-contrib-dev
+Architecture: any
+Section: contrib/libdevel
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: [% $description %] (contrib)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ This package is in the contrib/libdevel section.
diff --git a/t/recipes/checks/binaries/location/binaries-development-package-ships-elf-binary-in-path/build-spec/debian/rules b/t/recipes/checks/binaries/location/binaries-development-package-ships-elf-binary-in-path/build-spec/debian/rules
new file mode 100755
index 0000000..fe4db63
--- /dev/null
+++ b/t/recipes/checks/binaries/location/binaries-development-package-ships-elf-binary-in-path/build-spec/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
+include /usr/share/dpkg/buildflags.mk
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ set -e; for X in none same foreign contrib; do \
+ install -d debian/libmultiarch-$$X-dev/usr/bin; \
+ install -d debian/libmultiarch-$$X-dev/var/lib/private; \
+ install -m 755 true debian/libmultiarch-$$X-dev/usr/bin/$$X; \
+ install -m 755 true debian/libmultiarch-$$X-dev/var/lib/private/$$X; \
+ install -m 755 script debian/libmultiarch-$$X-dev/usr/bin/$$X-script; \
+ install -m 755 script debian/libmultiarch-$$X-dev/var/lib/private/$$X-script; \
+ done
+
+override_dh_strip:
+ # Avoid symbol conflicts warnings
+ dh_strip --no-automatic-dbgsym