summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/build-systems/autotools
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/build-systems/autotools')
-rw-r--r--t/recipes/checks/build-systems/autotools/cruft-general-test-suite/build-spec/fill-values3
-rw-r--r--t/recipes/checks/build-systems/autotools/cruft-general-test-suite/build-spec/orig/hello.c8
-rwxr-xr-xt/recipes/checks/build-systems/autotools/cruft-general-test-suite/build-spec/pre-upstream35
-rw-r--r--t/recipes/checks/build-systems/autotools/cruft-general-test-suite/eval/desc4
-rw-r--r--t/recipes/checks/build-systems/autotools/cruft-general-test-suite/eval/hints1
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool-2/build-spec/fill-values3
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool-2/build-spec/orig/ltmain.sh62
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool-2/eval/desc3
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool-2/eval/hints1
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/build-spec/fill-values3
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/build-spec/orig/ltconfig0
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/build-spec/orig/ltmain.sh59
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/eval/desc3
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/eval/hints2
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-current-libtool/build-spec/fill-values3
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-current-libtool/build-spec/orig/ltmain.sh48
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-current-libtool/eval/desc4
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-current-libtool/eval/hints0
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/build-spec/fill-values4
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/build-spec/orig/ltconfig0
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/build-spec/orig/ltmain.sh59
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/eval/desc4
-rw-r--r--t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/eval/hints0
-rw-r--r--t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/build-spec/fill-values3
-rw-r--r--t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/build-spec/orig/configure.in5
-rw-r--r--t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/build-spec/orig/src/configure.in1
-rw-r--r--t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/eval/desc2
-rw-r--r--t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/eval/hints2
-rw-r--r--t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/build-spec/fill-values3
-rw-r--r--t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/build-spec/orig/configure.ac5
-rw-r--r--t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/build-spec/orig/src/configure.ac1
-rw-r--r--t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/eval/desc2
-rw-r--r--t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/eval/hints2
33 files changed, 335 insertions, 0 deletions
diff --git a/t/recipes/checks/build-systems/autotools/cruft-general-test-suite/build-spec/fill-values b/t/recipes/checks/build-systems/autotools/cruft-general-test-suite/build-spec/fill-values
new file mode 100644
index 0000000..b153334
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/cruft-general-test-suite/build-spec/fill-values
@@ -0,0 +1,3 @@
+Testname: cruft-general-test-suite
+Skeleton: upload-non-native
+Description: Check that cruft in test suites is okay
diff --git a/t/recipes/checks/build-systems/autotools/cruft-general-test-suite/build-spec/orig/hello.c b/t/recipes/checks/build-systems/autotools/cruft-general-test-suite/build-spec/orig/hello.c
new file mode 100644
index 0000000..1b47b80
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/cruft-general-test-suite/build-spec/orig/hello.c
@@ -0,0 +1,8 @@
+#include <stdio.h>
+
+int
+main(void)
+{
+ printf("Hello world!\n");
+ return 0;
+}
diff --git a/t/recipes/checks/build-systems/autotools/cruft-general-test-suite/build-spec/pre-upstream b/t/recipes/checks/build-systems/autotools/cruft-general-test-suite/build-spec/pre-upstream
new file mode 100755
index 0000000..8665c92
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/cruft-general-test-suite/build-spec/pre-upstream
@@ -0,0 +1,35 @@
+#!/bin/sh
+#
+# Create all the various junk that shouldn't exist upstream. We do much of it
+# here rather than in the template so that Lintian itself can be imported into
+# revision control systems.
+
+set -e
+dir="$1"
+
+mkdir -p "${dir}/t/CVS"
+echo 'source-contains-cvs-control-dir' > "${dir}/t/CVS/Entries"
+mkdir -p "${dir}/foo/t/.svn"
+echo 'source-contains-svn-control-dir' > "${dir}/foo/t/.svn/format"
+mkdir -p "${dir}/test/.bzr"
+echo 'source-contains-bzr-control-dir' > "${dir}/test/.bzr/foo"
+mkdir -p "${dir}/bar/test/{arch}"
+echo 'source-contains-arch-control-dir' > "${dir}/bar/test/{arch}/foo"
+mkdir -p "${dir}/tests/.git"
+echo 'source-contains-git-control-dir' > "${dir}/tests/.git/foo"
+mkdir -p "${dir}/baz/foo/tests/.hg"
+echo 'source-contains-hg-control-dir' > "${dir}/baz/foo/tests/.hg/foo"
+mkdir -p "${dir}/testset/.be"
+echo 'source-contains-bts-control-dir' > "${dir}/testset/.be/foo"
+
+echo 'source-contains-svn-commit-file' > "${dir}/t/svn-commit.tmp"
+echo 'source-contains-svk-commit-file' > "${dir}/t/svk-commit444.tmp"
+echo 'source-contains-arch-inventory-file' > "${dir}/t/.arch-inventory"
+echo 'source-contains-hg-tags-file' > "${dir}/t/.hgtags"
+echo 'source-contains-cvs-conflict-copy' > "${dir}/t/.#foo.1.1"
+echo 'source-contains-svn-conflict-file' > "${dir}/t/foo.r1352"
+
+echo 'configure-generated-file-in-source' > "${dir}/tests/config.cache"
+
+cd "$1"
+gcc -o t/hello hello.c
diff --git a/t/recipes/checks/build-systems/autotools/cruft-general-test-suite/eval/desc b/t/recipes/checks/build-systems/autotools/cruft-general-test-suite/eval/desc
new file mode 100644
index 0000000..2da240a
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/cruft-general-test-suite/eval/desc
@@ -0,0 +1,4 @@
+Testname: cruft-general-test-suite
+Test-Against:
+ configure-generated-file-in-source
+Check: build-systems/autotools
diff --git a/t/recipes/checks/build-systems/autotools/cruft-general-test-suite/eval/hints b/t/recipes/checks/build-systems/autotools/cruft-general-test-suite/eval/hints
new file mode 100644
index 0000000..5f7a858
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/cruft-general-test-suite/eval/hints
@@ -0,0 +1 @@
+cruft-general-test-suite (source): configure-generated-file-in-source [tests/config.cache]
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool-2/build-spec/fill-values b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool-2/build-spec/fill-values
new file mode 100644
index 0000000..b6419d2
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool-2/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: cruft-ancient-libtool-2
+Description: Test that an old (1.5.2) ltmain.sh is detected correctly
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool-2/build-spec/orig/ltmain.sh b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool-2/build-spec/orig/ltmain.sh
new file mode 100644
index 0000000..662c6f0
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool-2/build-spec/orig/ltmain.sh
@@ -0,0 +1,62 @@
+# ltmain.sh - Provide generalized library-building support services.
+# NOTE: Changing this file will not affect anything until you rerun configure.
+#
+# Copyright (C) 1996, 1997, 1998, 1999, 2000, 2001, 2003
+# Free Software Foundation, Inc.
+# Originally by Gordon Matzigkeit <gord@gnu.ai.mit.edu>, 1996
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+# As a special exception to the GNU General Public License, if you
+# distribute this file as part of a program that contains a
+# configuration script generated by Autoconf, you may include it under
+# the same distribution terms that you use for the rest of that program.
+
+# Check that we have a working $echo.
+if test "X$1" = X--no-reexec; then
+ # Discard the --no-reexec flag, and continue.
+ shift
+elif test "X$1" = X--fallback-echo; then
+ # Avoid inline document here, it may be left over
+ :
+elif test "X`($echo '\t') 2>/dev/null`" = 'X\t'; then
+ # Yippee, $echo works!
+ :
+else
+ # Restart under the correct shell, and then maybe $echo will work.
+ exec $SHELL "$0" --no-reexec ${1+"$@"}
+fi
+
+if test "X$1" = X--fallback-echo; then
+ # used as fallback echo
+ shift
+ cat <<EOF
+$*
+EOF
+ exit 0
+fi
+
+# define SED for historic ltconfig's generated by Libtool 1.3
+test -z "$SED" && SED=sed
+
+# The name of this program.
+progname=`$echo "$0" | ${SED} 's%^.*/%%'`
+modename="$progname"
+
+# Constants.
+PROGRAM=ltmain.sh
+PACKAGE=libtool
+VERSION=1.5.2
+TIMESTAMP=" (1.1220.2.60 2004/01/25 12:25:08)"
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool-2/eval/desc b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool-2/eval/desc
new file mode 100644
index 0000000..3d83282
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool-2/eval/desc
@@ -0,0 +1,3 @@
+Testname: cruft-ancient-libtool-2
+See-Also: Debian Bug#293296
+Check: build-systems/autotools/libtool
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool-2/eval/hints b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool-2/eval/hints
new file mode 100644
index 0000000..1cc1820
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool-2/eval/hints
@@ -0,0 +1 @@
+cruft-ancient-libtool-2 (source): ancient-libtool 1.5.2 [ltmain.sh]
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/build-spec/fill-values b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/build-spec/fill-values
new file mode 100644
index 0000000..73ae4f6
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: cruft-ancient-libtool
+Description: Test that a very old ltmain.sh/ltconfig is detected correctly
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/build-spec/orig/ltconfig b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/build-spec/orig/ltconfig
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/build-spec/orig/ltconfig
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/build-spec/orig/ltmain.sh b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/build-spec/orig/ltmain.sh
new file mode 100644
index 0000000..c7b800b
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/build-spec/orig/ltmain.sh
@@ -0,0 +1,59 @@
+# ltmain.sh - Provide generalized library-building support services.
+# NOTE: Changing this file will not affect anything until you rerun ltconfig.
+#
+# Copyright (C) 1996-1999 Free Software Foundation, Inc.
+# Originally by Gordon Matzigkeit <gord@gnu.ai.mit.edu>, 1996
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+# As a special exception to the GNU General Public License, if you
+# distribute this file as part of a program that contains a
+# configuration script generated by Autoconf, you may include it under
+# the same distribution terms that you use for the rest of that program.
+
+# Check that we have a working $echo.
+if test "X$1" = X--no-reexec; then
+ # Discard the --no-reexec flag, and continue.
+ shift
+elif test "X$1" = X--fallback-echo; then
+ # Avoid inline document here, it may be left over
+ :
+elif test "X`($echo '\t') 2>/dev/null`" = 'X\t'; then
+ # Yippee, $echo works!
+ :
+else
+ # Restart under the correct shell, and then maybe $echo will work.
+ exec $SHELL "$0" --no-reexec ${1+"$@"}
+fi
+
+if test "X$1" = X--fallback-echo; then
+ # used as fallback echo
+ shift
+ cat <<EOF
+$*
+EOF
+ exit 0
+fi
+
+# The name of this program.
+progname=`$echo "$0" | sed 's%^.*/%%'`
+modename="$progname"
+
+# Constants.
+PROGRAM=ltmain.sh
+PACKAGE=libtool
+VERSION=1.3.5
+TIMESTAMP=" (1.385.2.206 2000/05/27 11:12:27)"
+
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/eval/desc b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/eval/desc
new file mode 100644
index 0000000..b7444e3
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/eval/desc
@@ -0,0 +1,3 @@
+Testname: cruft-ancient-libtool
+See-Also: Debian Bug#293296
+Check: build-systems/autotools/libtool
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/eval/hints b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/eval/hints
new file mode 100644
index 0000000..c81096c
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-ancient-libtool/eval/hints
@@ -0,0 +1,2 @@
+cruft-ancient-libtool (source): ancient-libtool [ltconfig]
+cruft-ancient-libtool (source): ancient-libtool 1.3.5 [ltmain.sh]
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-current-libtool/build-spec/fill-values b/t/recipes/checks/build-systems/autotools/libtool/cruft-current-libtool/build-spec/fill-values
new file mode 100644
index 0000000..25f81aa
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-current-libtool/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: cruft-current-libtool
+Description: Test that a current ltmain.sh is detected correctly
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-current-libtool/build-spec/orig/ltmain.sh b/t/recipes/checks/build-systems/autotools/libtool/cruft-current-libtool/build-spec/orig/ltmain.sh
new file mode 100644
index 0000000..c5f7e11
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-current-libtool/build-spec/orig/ltmain.sh
@@ -0,0 +1,48 @@
+# ltmain.sh - Provide generalized library-building support services.
+# NOTE: Changing this file will not affect anything until you rerun configure.
+#
+# Copyright (C) 1996, 1997, 1998, 1999, 2000, 2001, 2003, 2004, 2005, 2006,
+# 2007 Free Software Foundation, Inc.
+# Originally by Gordon Matzigkeit <gord@gnu.ai.mit.edu>, 1996
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+#
+# As a special exception to the GNU General Public License, if you
+# distribute this file as part of a program that contains a
+# configuration script generated by Autoconf, you may include it under
+# the same distribution terms that you use for the rest of that program.
+
+basename="s,^.*/,,g"
+
+# Work around backward compatibility issue on IRIX 6.5. On IRIX 6.4+, sh
+# is ksh but when the shell is invoked as "sh" and the current value of
+# the _XPG environment variable is not equal to 1 (one), the special
+# positional parameter $0, within a function call, is the name of the
+# function.
+progpath="$0"
+
+# The name of this program:
+progname=`echo "$progpath" | $SED $basename`
+modename="$progname"
+
+# Global variables:
+EXIT_SUCCESS=0
+EXIT_FAILURE=1
+
+PROGRAM=ltmain.sh
+PACKAGE=libtool
+VERSION="1.5.24 Debian 1.5.24-1ubuntu1"
+TIMESTAMP=" (1.1220.2.456 2007/06/24 02:25:32)"
+
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-current-libtool/eval/desc b/t/recipes/checks/build-systems/autotools/libtool/cruft-current-libtool/eval/desc
new file mode 100644
index 0000000..1d949a7
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-current-libtool/eval/desc
@@ -0,0 +1,4 @@
+Testname: cruft-current-libtool
+Test-Against: ancient-libtool
+See-Also: Debian Bug#293296
+Check: build-systems/autotools/libtool
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-current-libtool/eval/hints b/t/recipes/checks/build-systems/autotools/libtool/cruft-current-libtool/eval/hints
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-current-libtool/eval/hints
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/build-spec/fill-values b/t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/build-spec/fill-values
new file mode 100644
index 0000000..7040ad7
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/build-spec/fill-values
@@ -0,0 +1,4 @@
+Skeleton: upload-native
+Testname: cruft-updated-libtool
+Extra-Build-Depends: libtool
+Description: Old ltmain.sh/ltconfig is fine with build-depend
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/build-spec/orig/ltconfig b/t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/build-spec/orig/ltconfig
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/build-spec/orig/ltconfig
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/build-spec/orig/ltmain.sh b/t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/build-spec/orig/ltmain.sh
new file mode 100644
index 0000000..c7b800b
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/build-spec/orig/ltmain.sh
@@ -0,0 +1,59 @@
+# ltmain.sh - Provide generalized library-building support services.
+# NOTE: Changing this file will not affect anything until you rerun ltconfig.
+#
+# Copyright (C) 1996-1999 Free Software Foundation, Inc.
+# Originally by Gordon Matzigkeit <gord@gnu.ai.mit.edu>, 1996
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+# As a special exception to the GNU General Public License, if you
+# distribute this file as part of a program that contains a
+# configuration script generated by Autoconf, you may include it under
+# the same distribution terms that you use for the rest of that program.
+
+# Check that we have a working $echo.
+if test "X$1" = X--no-reexec; then
+ # Discard the --no-reexec flag, and continue.
+ shift
+elif test "X$1" = X--fallback-echo; then
+ # Avoid inline document here, it may be left over
+ :
+elif test "X`($echo '\t') 2>/dev/null`" = 'X\t'; then
+ # Yippee, $echo works!
+ :
+else
+ # Restart under the correct shell, and then maybe $echo will work.
+ exec $SHELL "$0" --no-reexec ${1+"$@"}
+fi
+
+if test "X$1" = X--fallback-echo; then
+ # used as fallback echo
+ shift
+ cat <<EOF
+$*
+EOF
+ exit 0
+fi
+
+# The name of this program.
+progname=`$echo "$0" | sed 's%^.*/%%'`
+modename="$progname"
+
+# Constants.
+PROGRAM=ltmain.sh
+PACKAGE=libtool
+VERSION=1.3.5
+TIMESTAMP=" (1.385.2.206 2000/05/27 11:12:27)"
+
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/eval/desc b/t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/eval/desc
new file mode 100644
index 0000000..8361e6e
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/eval/desc
@@ -0,0 +1,4 @@
+Testname: cruft-updated-libtool
+Test-Against: ancient-libtool
+See-Also: Debian Bug#534134
+Check: build-systems/autotools/libtool
diff --git a/t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/eval/hints b/t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/eval/hints
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/libtool/cruft-updated-libtool/eval/hints
diff --git a/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/build-spec/fill-values b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/build-spec/fill-values
new file mode 100644
index 0000000..17ea1fd
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: source-native
+Testname: macro-not-cross-compilation-safe-old-filename
+Description: Check for packages that look for pkg-config incorrectly
diff --git a/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/build-spec/orig/configure.in b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/build-spec/orig/configure.in
new file mode 100644
index 0000000..22ab789
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/build-spec/orig/configure.in
@@ -0,0 +1,5 @@
+AC_INIT
+
+AC_PATH_PROG(PKGCONFIG, pkg-config, no, $PATH:/usr/bin:/usr/local/bin)
+
+ dnl AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
diff --git a/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/build-spec/orig/src/configure.in b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/build-spec/orig/src/configure.in
new file mode 100644
index 0000000..eeb7274
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/build-spec/orig/src/configure.in
@@ -0,0 +1 @@
+AC_PATH_PROG(PKGCONFIG, pkg-config, no, $PATH:/usr/bin:/usr/local/bin)
diff --git a/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/eval/desc b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/eval/desc
new file mode 100644
index 0000000..da64458
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/eval/desc
@@ -0,0 +1,2 @@
+Testname: macro-not-cross-compilation-safe-old-filename
+Check: build-systems/autotools
diff --git a/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/eval/hints b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/eval/hints
new file mode 100644
index 0000000..8e6791b
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe-old-filename/eval/hints
@@ -0,0 +1,2 @@
+macro-not-cross-compilation-safe-old-filename (source): autotools-pkg-config-macro-not-cross-compilation-safe AC_PATH_PROG [src/configure.in:1]
+macro-not-cross-compilation-safe-old-filename (source): autotools-pkg-config-macro-not-cross-compilation-safe AC_PATH_PROG [configure.in:3]
diff --git a/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/build-spec/fill-values b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/build-spec/fill-values
new file mode 100644
index 0000000..c13e4d5
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: source-native
+Testname: macro-not-cross-compilation-safe
+Description: Check for packages that look for pkg-config incorrectly
diff --git a/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/build-spec/orig/configure.ac b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/build-spec/orig/configure.ac
new file mode 100644
index 0000000..4e448c8
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/build-spec/orig/configure.ac
@@ -0,0 +1,5 @@
+AC_INIT
+
+AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
+
+dnl AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
diff --git a/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/build-spec/orig/src/configure.ac b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/build-spec/orig/src/configure.ac
new file mode 100644
index 0000000..0250f9b
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/build-spec/orig/src/configure.ac
@@ -0,0 +1 @@
+AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
diff --git a/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/eval/desc b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/eval/desc
new file mode 100644
index 0000000..c4022ba
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/eval/desc
@@ -0,0 +1,2 @@
+Testname: macro-not-cross-compilation-safe
+Check: build-systems/autotools
diff --git a/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/eval/hints b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/eval/hints
new file mode 100644
index 0000000..caf4c75
--- /dev/null
+++ b/t/recipes/checks/build-systems/autotools/macro-not-cross-compilation-safe/eval/hints
@@ -0,0 +1,2 @@
+macro-not-cross-compilation-safe (source): autotools-pkg-config-macro-not-cross-compilation-safe AC_PATH_PROG [src/configure.ac:1]
+macro-not-cross-compilation-safe (source): autotools-pkg-config-macro-not-cross-compilation-safe AC_PATH_PROG [configure.ac:3]