summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated')
-rwxr-xr-xt/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec/debian/rules37
-rw-r--r--t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec/fill-values4
-rw-r--r--t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/eval/desc2
-rw-r--r--t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/eval/hints5
4 files changed, 48 insertions, 0 deletions
diff --git a/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec/debian/rules b/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec/debian/rules
new file mode 100755
index 0000000..bd004e3
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec/debian/rules
@@ -0,0 +1,37 @@
+#!/usr/bin/make -f
+#
+# Use an alternate rules file that doesn't call dh to test not warning
+# about debhelper script tokens if we call no programs that care about
+# them.
+
+pkg = $(shell dh_listpackages)
+
+build: build-arch build-indep
+build-arch:
+build-indep:
+
+clean:
+ dh_testdir
+ dh_testroot
+ dh_clean
+
+binary: binary-indep binary-arch
+binary-arch:
+binary-indep:
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_install
+ dh_installchangelogs
+ dh_installdebconf
+ # dh_installdocs may modify maintainer scripts
+ install -m 644 debian/copyright debian/$(pkg)/usr/share/doc/$(pkg)
+ dh_link
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+.PHONY: build-arch build-indep build binary binary-arch binary-indep clean
diff --git a/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec/fill-values b/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec/fill-values
new file mode 100644
index 0000000..c836ef5
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/build-spec/fill-values
@@ -0,0 +1,4 @@
+Skeleton: upload-native
+Testname: debhelper-dh-clean-k-deprecated
+Dh-Compat-Level: 11
+Description: Test for debhelper >=7 packages using dh_clean -k
diff --git a/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/eval/desc b/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/eval/desc
new file mode 100644
index 0000000..7742990
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/eval/desc
@@ -0,0 +1,2 @@
+Testname: debhelper-dh-clean-k-deprecated
+Check: debhelper
diff --git a/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/eval/hints b/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/eval/hints
new file mode 100644
index 0000000..a21c10f
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-dh-clean-k-deprecated/eval/hints
@@ -0,0 +1,5 @@
+debhelper-dh-clean-k-deprecated (source): package-uses-old-debhelper-compat-version 11
+debhelper-dh-clean-k-deprecated (source): dh-clean-k-is-deprecated [debian/rules]
+debhelper-dh-clean-k-deprecated (source): debian-build-system debhelper [debian/rules]
+debhelper-dh-clean-k-deprecated (source): debhelper-compat-virtual-relation 11 [debian/control]
+debhelper-dh-clean-k-deprecated (source): debhelper-compat-level 11