summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debhelper/debhelper-dh-runit-but-lacks-breaks-substvar/build-spec
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/debhelper/debhelper-dh-runit-but-lacks-breaks-substvar/build-spec')
-rw-r--r--t/recipes/checks/debhelper/debhelper-dh-runit-but-lacks-breaks-substvar/build-spec/debian/control.in42
-rwxr-xr-xt/recipes/checks/debhelper/debhelper-dh-runit-but-lacks-breaks-substvar/build-spec/debian/rules11
-rw-r--r--t/recipes/checks/debhelper/debhelper-dh-runit-but-lacks-breaks-substvar/build-spec/fill-values3
3 files changed, 56 insertions, 0 deletions
diff --git a/t/recipes/checks/debhelper/debhelper-dh-runit-but-lacks-breaks-substvar/build-spec/debian/control.in b/t/recipes/checks/debhelper/debhelper-dh-runit-but-lacks-breaks-substvar/build-spec/debian/control.in
new file mode 100644
index 0000000..07c5e61
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-dh-runit-but-lacks-breaks-substvar/build-spec/debian/control.in
@@ -0,0 +1,42 @@
+Source: [% $source %]
+Priority: optional
+Section: python
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %], dh-runit
+Rules-Requires-Root: no
+
+Package: [% $source %]-missing
+Architecture: [% $package_architecture %]
+Depends: ${misc:Depends}, runit
+Description: [% $description %] (true positive)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Missing breaks.
+
+Package: [% $source %]-present
+Architecture: [% $package_architecture %]
+Depends: ${misc:Depends}, runit
+Breaks: ${runit:Breaks}
+Description: [% $description %] (false positive)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Has breaks.
+
+Package: [% $source %]-unrelated
+Architecture: all
+Depends: ${misc:Depends}
+Breaks: ${runit:Breaks}
+Description: [% $description %] (unrelated)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ No, breaks, but unrelated.
diff --git a/t/recipes/checks/debhelper/debhelper-dh-runit-but-lacks-breaks-substvar/build-spec/debian/rules b/t/recipes/checks/debhelper/debhelper-dh-runit-but-lacks-breaks-substvar/build-spec/debian/rules
new file mode 100755
index 0000000..25cfa28
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-dh-runit-but-lacks-breaks-substvar/build-spec/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ --with runit
+
+override_dh_auto_install:
+ dh_auto_install
+ for X in $(shell dh_listpackages); do \
+ mkdir -p debian/$$X/etc/sv; \
+ touch debian/$$X/etc/sv/$$X; \
+ done
diff --git a/t/recipes/checks/debhelper/debhelper-dh-runit-but-lacks-breaks-substvar/build-spec/fill-values b/t/recipes/checks/debhelper/debhelper-dh-runit-but-lacks-breaks-substvar/build-spec/fill-values
new file mode 100644
index 0000000..1fab39d
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-dh-runit-but-lacks-breaks-substvar/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: debhelper-dh-runit-but-lacks-breaks-substvar
+Description: Check Breaks requirements for dh --with dh_runit