summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debhelper/debhelper-no-depends/build-spec/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/debhelper/debhelper-no-depends/build-spec/debian/rules')
-rwxr-xr-xt/recipes/checks/debhelper/debhelper-no-depends/build-spec/debian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/t/recipes/checks/debhelper/debhelper-no-depends/build-spec/debian/rules b/t/recipes/checks/debhelper/debhelper-no-depends/build-spec/debian/rules
new file mode 100755
index 0000000..a622013
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-no-depends/build-spec/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+%:
+ dh $@
+
+binary: binary-arch binary-indep
+binary-arch:
+binary-indep:
+ -dh_clideps
+ -dh_gstscancodecs
+ dh_lisp || true
+ # Should trigger a versioned dependency requirement for dpatch
+ -dh_dpatch_patch
+# We don't warn about commands inside make conditionals, so none of these
+# get any warnings.
+ifeq "$(USE_DH_PYTHON3)" "y"
+ dh_python3
+else
+ ifeq "$(USE_PYSUPPORT)" "y"
+ dh_pysupport
+ endif
+endif
+ dh binary-indep
+ -dh_strip_nondeterminism
+ -dh_scour